• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Docker cannot find image
#1
Hello together,

seams to me like I got my head stuck in the cupboard.

I triy to set up the NetPi image in Portainer to get my own Node.JS running on that system But everytime pulling the image "hilschernetpi/netpi-raspbian" from the Docker Hub:
https://hub.docker.com/r/hilschernetpi/netpi-raspbian

I got the same message:  Failure - No such image: hilschernetpi/netpi-raspbian:latest

I have checked the RTC in the control-panel, and the networt of eth0 runs on DHCP. As last chance I took all the bones to home to be sure no company firewall blocks me. But nothings works, still getting the same error all the time.

What's my failure?

Kind regards,

Carsten Oswald
  Reply
#2
Well we are selling netPI since 2016 and the only cases I had ever heard of reporting this error was always the netPI system time that was out of sync compared to the Docker Hub time.

But since version V1.2.0.0 (July 2019) of netPI's system software we have anyway an NTP server pre-configured, which wasn't in earlier version and to be honest since this release I have never heard of any user having this problem again.

Just for a cross check. Do you have a Raspberry Pi located in the same network maybe and can call "docker pull hilschernetpi/netpi-raspbian" from a command shell to check if this works?

And please double check the system time again and also the location and hour shift setup.

I checked pulling the image just a minute again myself with my netPI to check if Dockerhub is down, but it works fine as it should.

If nothing helps the last thing I have in mind it to recover the unit to default state using the system sofware package and USB stick from here https://www.netiot.com/netpi/industrial-raspberry-pi-3/ in the download section

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Thank you for your suppert,

sorry, no raspberry available.

I have attached some screenshots. Time is good, it's syncronized with TU Berlin.

   

The network is a little bit confusing.

The hardware in in the Fritz.box 192.168.1.0 segment, while the docker bridge is about 172.0.0.0 segment. Where is the routing between these segment?

   

   

Glad to hear from you.

Carsten
  Reply
#4
What else TCP/IP interfaces next to eth0 and cifx0 do you have active? wlan0 also? Can't see it in your screen shot.

And yes ALL containers that are later deployed in bridged mode on a Docker host device are held under the separate subnet 172.x.x.x.. This is normal.

But first of all you need to get at least your first image loaded anyways.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#5
There is another remark I have. Your device is of type NIOT-E-TPI51-EN-RE. This device we call "Connect" gateway of the series netIOT. This is no netPI.

I agree that this device supports Docker also and most of the threads in this forum apply to this device also, but still it is no netPI and officially not supported by this forums. The official support for this devices goes over www.hilscher.com and a support ticket system.

Independent pulling of a simple Docker image from the Docker Hub repo "Connect" and "netPI" work the same and must work right away.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#6
The reason why I was asking for the wlan0 interface is that if you configure your LAN connection eth0 and at the same time the wlan0 interface with both a gateway configured then Linux does not know where to send out the TCP/IP frames that are of external destination. So you have to decide which of the data path you give priority and remove the gateway for example in the wlan0 settings.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#7
Good morning,

I'ved checked this.

WLAN is disabled and routing seams to be standard.

   

   

So the packets have no chance to take te wrong way.

Hopefully waiting for reply,

Carsten
  Reply
#8
Well I am at the end of my thougths. I have no explanation why it does not work.

So just to make sure how your hardware setup is ... there is a router like the Fritzbox ... and there is the "connect" gateway we are talking about ... maybe some other devices and there is your desktop PC you are accessing the gateway across. Is my understanding correct?

Since I realized now you have a "connect" gateway and not a netPI the software of this type of device can be loaded from here https://www.hilscher.com/fileadmin/big_d...9-07-1.zip

The last thing I have in mind is to reset the software to the default state using an USB stick with the correct data package in the link above. Please give it a try.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#9
Hello Armin,


this was my intention too, so I overwrite the box this morning...
... with any improvement.

After renewed firmware, the box was totally fresh, asked me for a new admin password.
Checking network -> got the same IP-addresss from the DHCP-server.
First thing, was to enter the right time-servers and zone.
Second step activate Docker
Third step - restart the box


Then trying to pull a docker-image... nope!

kind regards,

Carsten
  Reply
#10
Hello Carsten,

sounds really odd to me. The docker deamon is nothing that Hilscher has any influence on under Linux. It just sends requests to IP addresses as any other Linux program too. And since Docker Hub is a trusted registry there is no parameter that has to be entered additional when pulling an image. Can you please make a screen shot of what you entered exactly before you klick "pull" please.

The device creates a log file under "system". Is it possible to send it?

The question about your network setup was not answered. So please answer this as well.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  docker.service start failed EUROKEY 9 392 July-20th-2020, 10:01 AM
Last Post: Armin@netPI
  PHP-Apache Image hsammer 3 172 March-12th-2020, 05:23 PM
Last Post: hsammer
  After „Rebuild“ of Docker neither the node-RED nor the dashboard can be accessed MAK 4 405 January-31st-2020, 02:14 PM
Last Post: MAK
  [SOLVED] Docker GUI login issue MGharat 1 225 September-19th-2019, 11:50 AM
Last Post: Armin@netPI
Information netPI Docker REST API for versions >= V1.1.4.0 patrick 1 328 July-16th-2019, 02:45 PM
Last Post: patrick
  [SOLVED] Pull Docker Image a.w.d.m. 8 327 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  [SOLVED] Docker issues AlexRegev 7 466 June-26th-2019, 02:14 PM
Last Post: AlexRegev
  docker timing MGharat 2 200 June-13th-2019, 08:57 AM
Last Post: patrick
  Launching multi-containers at a time - Docker stacks Armin@netPI 0 249 June-4th-2019, 04:11 PM
Last Post: Armin@netPI
  [INFO]Docker DNS server Armin@netPI 0 125 March-7th-2019, 09:02 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)