• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Docker not enabled
#1
Dear Armin,

I got information that Docker is not enabled (grayed-out) on the edge gateway manager (Web GUI) even the following settings were done.

In Services menu in Control panel:
- Operating status = Running
- Autostart = enabled is selected

A monitor is connected to netPI to get the attached log status.
Would you please refer to the attached file?
If you find anything wrong, it would be helpful for me.

Should I restore the netPI recover image?

Thank you very much for your support.
Best regards,


Attached Files Thumbnail(s)
   
  Reply
#2
Yes this issue has been solved in the very latest netPI software V1.2.2.0.

Other customers had the very same problem like you and we have analysed the problem.

If you download the latest system software from here https://www.hilscher.com/fileadmin/big_d..._V1220.zip you see that it is mentioned in the changelog file as solved:     "- fixed docker daemon problem prohibiting docker service to start after a power cycle caused by an "empty" docker configuration file /etc/docker/daemon.json by replacing it with a backup file"

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Dear Armin,

Thank you very much for your quick response.
I understand so I restore the latest system software V1.2.2.0.

Best regards,
  Reply
#4
Hello everybody,

today I also got trapped into this issue with v1.2.0.0 and so I have to update the box.

Is this finally solved now? Our solution is biuld within the docker enviroment.

Kind regards,

Carsten
  Reply
#5
System Software V1.2.2.0 solves this problem and Docker will remained enabled all the time after it has been activated once.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#6
Maybe I'm in the wrong Thread.
My box is a NIOT-E-tpi51-EN-RE, not a pure netPI.
The last good version hererfore is 1.2.1.0 ?

Kind regards,

Carsten
  Reply
#7
Well indeed ... netPI and netIOT Connect Edge Gateway - which is the device you are using - are differently handled in terms of support.

netPI is a device supported through this forum only and has an official landing page under https://www.netiot.com/netpi/industrial-raspberry-pi-3/ while the netIOT Connect Gateway (V1.x generation of software) is supported through the Hilscher hotline team and ticket system addressing all inquiries to support@hilscher.com and is advertised on www.hilscher.com web site in the section Industrial IOT. Additionally the netIOT Edge Device series was dedicated a knowledge base page which is located on Hilscher's kb.hilscher.com knowledge base under https://kb.hilscher.com/x/yh-mBQ

I agree that version of software V1.2.1.0 was made public and V1.2.2.0 version remained in the backgroup. I updated the page https://kb.hilscher.com/x/kTMfBw just some minutes ago, to bring the latest software V1.2.2.0 to the front.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#8
O.key...
... is there a possibility to "save" the containers before making the firmware update?
  Reply
#9
Yes this is possible using netPI portainer web-ui.

Go to the container overiew list click the container of interest. Then stop it first. In the same menu there is a feature called the "create image". Use it and give the image a reasonable name. The images is save on netPI. This may take a while.

Then go to the images overview list. Click the image you have created and use the "export" function. This creates a compressed file of the whole image and its contents and it offers you the container as download file in the web browser. This takes 10 minutes so be patient.

Later when netPI is updated you can go in the images overview list and use the import function to import the image. Then just simply start the container from that image and it will be right there as before the update.

Thx
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#10
Hello Armin,

thanks for  publishing the latest firmware. With export/import the workload-container the firmware-update was done very fast.

But I kept the problem with hilschernetpi/netpi-netx-ethernet-lan:1.1.1 - Container. If i try  to use hilschernetpi/netpi-netx-ethernet-lan:1.1.3 I'm even not able to ping my PLC at the cifx0 port. Simply change the image of the Container down to 1.1.1 - and it instantly works fine. also my workload than can communicate with the controller.

Kind regards,

Carsten
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Docker exposed port don't send data on eth0 COswald 3 394 July-15th-2021, 02:10 PM
Last Post: Armin@netPI
  Docker amd64 instead of arm biancode 3 816 January-17th-2021, 09:40 PM
Last Post: Armin@netPI
  docker.service start failed EUROKEY 13 3,496 January-17th-2021, 07:52 PM
Last Post: Armin@netPI
  Docker cannot find image COswald 16 3,376 May-18th-2020, 07:15 AM
Last Post: COswald
  After „Rebuild“ of Docker neither the node-RED nor the dashboard can be accessed MAK 4 1,902 January-31st-2020, 02:14 PM
Last Post: MAK
  [SOLVED] Docker GUI login issue MGharat 1 1,026 September-19th-2019, 11:50 AM
Last Post: Armin@netPI
Information netPI Docker REST API patrick 1 1,724 July-16th-2019, 02:45 PM
Last Post: patrick
  [SOLVED] Pull Docker Image a.w.d.m. 8 1,878 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  [SOLVED] Docker issues AlexRegev 7 2,196 June-26th-2019, 02:14 PM
Last Post: AlexRegev
  docker timing MGharat 2 1,053 June-13th-2019, 08:57 AM
Last Post: patrick

Forum Jump:


Users browsing this thread: 1 Guest(s)