• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PHP-Apache Image
I tried several times to pull the image "php:7.4-apache" from Dockerhub.
Everything seems to work fine; the green box appears and states "success", but the image is not listed in the image history  and not available for containers.
Doing the same on my development raspberry -> everything is working as expected.
The difference: On the development raspberry portainer 1.22.1 is running, on netPi 1.20.1.
Pulling this image from my own registry works.

I appreciate any ideas.
To be honest after 3 years of netPI meanwhile I have never heard of any Docker image that was not pulled.

Which firmware version on netPI are you using?

How about to pull any other image to check if this specifically a problem of this image?

Portainer will never be the root cause of this problem for sure ... Portainer just uses the API calls from the Docker runtime engine that is running inside netPI.

I specifically looked to the size of the image which is about 150Mbyte and I would call this size "small". Pulling should be a thing of 5 minutes then. When I am back to the office I could try it on my netPI to pull it and see the results. I will keep you informed what I found out.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

No problem here. Image pulled in 5 minutes fine.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Thank you for your fast reply and the test.

Maybe it's only a presentation problem within portainer.
Rebooting netPi seems to have solved the problem.

Possibly Related Threads…
Thread Author Replies Views Last Post
  netPI opc ua server pull image error wswitula 3 968 August-27th-2021, 10:47 AM
Last Post: wswitula
  Docker cannot find image COswald 16 3,951 May-18th-2020, 07:15 AM
Last Post: COswald
  [SOLVED] Pull Docker Image a.w.d.m. 8 2,429 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  [SOLVED] node-red Dashboard Docker Image for netPI? anrodriguez 1 1,686 February-7th-2019, 05:35 PM
Last Post: Armin@netPI
  [INFO] Best base image to use for own containers Armin@netPI 1 1,630 January-15th-2019, 08:58 PM
Last Post: Armin@netPI
  [SOLVED] nodered : flows_localhost deleted after creating an image from container paubau 6 2,007 September-21st-2018, 10:19 AM
Last Post: paubau
  Pull image does not work Jonas.Sellmann@outlook.de 3 1,490 August-1st-2018, 08:07 AM
Last Post: Armin@netPI
  "node-red with NIOT-E-NPIX-EVA GPIO module" Docker image Eyad.Almolki 1 1,029 July-30th-2018, 06:22 PM
Last Post: Armin@netPI
  [SOLVED] "Image unavailable" “no such image” message during deploy Armin@netPI 3 1,656 March-15th-2018, 04:47 PM
Last Post: kwapphiell
  Using SSH in netPI-nodered-fieldbus image Schranz 3 1,999 March-6th-2018, 06:29 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)