• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] "Image unavailable" “no such image” message during deploy
KWhenever an image is loaded from Docker Hub a certificate is exhanged between the device that pulls the image and the Docker site. This is because of security reasons. The certificate contains next to others also an information about when it was created and until it is valid. During the pulling process Docker Hub compares these times against its system time to release an image or not.

If now the expiration time - even if it is just a second - is in the past and signals the image certificate has expired an image cannot be loaded. So on netPI the same scenario happens if netPI's system time is not set up right and different to the actual time Docker Hub is referencing on ... an "image unavailable" message is reported in this case although available on Docker Hub. So make sure you manually set netPI's time correctly or setup an NTP server keeping an eye on the system time automatically.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Our setup....
netPI Firmware
Status: Synchronized to time server (ts1.univie.ac.at).
Timezone: Europe/Vienna
Portainer v1.12.4
problem installing "any" container like "hilschernetpi/netpi-raspbian" results in "No such image: hilschernetpi/netpi-raspbian:latest"

Our testnetwork is connected over an tp-link 4G lte-router to the internet.
Ideas ?
Well Docker will pull by default from Docker hub across port 5000. Maybe this port isn't allowed to be sent data across in your router.
Do you use a DHCP ip address setting? Or have you configured a static IP address?

Also a question is if you have a Raspberry Pi 3 in the same network where you can call "docker pull hilschernetpi/netpi-raspbian" manually. It will show the same effect, I am pretty sure.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

This was the solution - thank you!

Possibly Related Threads...
Thread Author Replies Views Last Post
  Docker cannot find image COswald 16 68 May-18th-2020, 07:15 AM
Last Post: COswald
  PHP-Apache Image hsammer 3 11 March-12th-2020, 05:23 PM
Last Post: hsammer
  Ready-to-deploy: full featured Node-RED container Armin@netPI 5 89 July-25th-2019, 06:16 AM
Last Post: Armin@netPI
  [SOLVED] Pull Docker Image a.w.d.m. 8 46 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  [SOLVED] node-red Dashboard Docker Image for netPI? anrodriguez 1 38 February-7th-2019, 05:35 PM
Last Post: Armin@netPI
  [SOLVED] Keep getting a message that session expired in Docker SteveO 2 43 January-24th-2019, 11:50 AM
Last Post: Armin@netPI
  [INFO] Best base image to use for own containers Armin@netPI 1 118 January-15th-2019, 08:58 PM
Last Post: Armin@netPI
  [SOLVED] nodered : flows_localhost deleted after creating an image from container paubau 6 191 September-21st-2018, 10:19 AM
Last Post: paubau
  Pull image does not work Jonas.Sellmann@outlook.de 3 197 August-1st-2018, 08:07 AM
Last Post: Armin@netPI
  "node-red with NIOT-E-NPIX-EVA GPIO module" Docker image Eyad.Almolki 1 149 July-30th-2018, 06:22 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)