• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] How to update firmware
How can I check if I have latest firmware installed on my device? In the control panel area on menu “System -> Info Center” I can see that V1.1.0.0 is installed. See screenshot:

[Image: m3zXW5S.png]

Is there a website where I can check the latest firmware version? I tried GitHub but without success:

And if there is a newer version available, how can I update? Respectively is there a website that describes the update procedure? There is no description in https://www.netiot.com/fileadmin/user_up..._01_EN.pdf regarding this topic.

Many thanks for your feedback in advance!
netPI has a landing page where you get all those information from you requested: https://www.netiot.com/netpi/industrial-raspberry-pi-3/

The forum here is just a little part of the whole "picture". Also you find informations about what to do for a firmware update in the FAQ section.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Detecting the loaded software version is possible without a login by the way. See attached screen shot.

Attached Files Thumbnail(s)
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Thank you Armin@netPI for your feedback. I was able to update as in https://www.netiot.com/netpi/industrial-...-on-netpi/ described.

I performed following steps.
  1. For a netPI recovery you need a USB stick of a size of 1GB minimum.
  2. The USB stick has to be FAT32 formatted. Make a full format instead of quick format. Best results if formatted on a Linux system
  3. Set the volume name of your USB stick to the string "RECOVERY" (all capital letters)
  4. Take  the relevant *.zip file from the subfolder and unzip its content and structure onto the USB stick's root folder in a whole. (folders: overlays, pre_overlays files: bcm2710-rpi-3-b.dtb ...)
  5. Apply the USB stick in any of your netPI available USB ports.
  6. Shutdown your netPI properly
  7. Let your netPI boot. The device's bootloader will detect the USB media and will automatically start the recovery procedure.
  8. The recovery will take up to 5 minutes. During the procedure you will see the APL LED flashing on the device's front.
  9. After the recovery is finished the device will automatically shutdown. Also the flasing APL LED will go to state "off".
  10. Remove the USB stick. The recovery is finished. Use netPI as usal.
Remark: Please be aware of the fact that not every USB stick works.  It needs to boot fast to get recognized by the Edge Gateway's bootloader when powered. Try out other sticks just in case.
Hello all,

the FAQ section states:

2. Upgrading software parts: Use netPI's web control panel to apply selective software packages over the menu item "Package Manager". One or multiple packages can be selected, uploaded to netPI and installed one after the other. Those packages are installed with immediate effect not needing any reset.

Where can I find those packages and futhermore what can be updated with those packages?
Is it possible to only update Portainer?

Is the only way to Update a net Pi's Firmware via USB or is there another way via those packages?

Best regards
Hello back,

yes it is correct that next to the USB firmware update procedure, we can provide also packages in case of need that allows users to update specific host linux or appliation parts within netPI.

Till today there was no need to publish any of those packages. So far we were providing whole images you can load into netPI via the USB procedure you mentioned.

To the question about portainer. We have seen the same need to have a portainer 1.19.x version active in netPI. In the next software release coming in November, we will have portainer V1.19.2 active.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hello again,

the FAQ states that the procedure is a Resetting to factory default.
But I don't want to lose the settings done on the net Pi.
Is there a way to update the sytem without resetting it.
I have a netPi installed in my network and it would be a pain to configure it again.

Best regards
Hello Flo, I am sorry to say that all firmwares for netPI we provide till today are resetting the unit back to factoy default.

With the next software release coming in November this will be the first release of software where all future software releases following will be delivered in two versions. One is the factory default image like we have it today and an upgrade version that keeps all settings like they are. But first we have to reach the status of the November release when we include the kernel 4.14 as Raspbian is already supporting it today.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Okay that's good.
Thank's for the answer.

Sorry for the necro, but I'm having some trouble updating the firmware. I put the files on a USB stick and repowered the device. The FAQ states, that the device indicates the update procedure by a flashing ACT light. Problem is, the ACT light is *always* flashing when the device is running, so I have no way of telling whether the device is actually updating.

How long is the procedure supposed to take? I waited around 30 minutes and it still hasn't reached the state where the ACT light lights up for a second and then goes of. I can still go into the control panel and it says V1.1.2.0.

Is it save to repower the device again or could that break something?

Possibly Related Threads…
Thread Author Replies Views Last Post
  netPI-netx-programming-examples update slos 12 662 September-14th-2020, 07:06 PM
Last Post: Armin@netPI
  Software update without factory defaults hannes 3 213 March-19th-2019, 11:57 AM
Last Post: patrick
  Suggestion for NetPi Update process vdupont 3 332 February-14th-2018, 09:32 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)