• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Docker issues
#1
Hi,

I'm having trouble installing new containers on my NetPI RTE plarform.
I'm getting errors such as 
"Unexpected token < in JSON at positions 1"

and 

"Cannot read property 'replace' of null

It keeps on happening with different containers but sometimes the installation is successful.
I am following your installation instructions exactly. 

Appreciate your help on this.

Alex

In addition i have constant red LED set on the NetPI (Err NS) I'm not sure if this is related but i'm wondering what is causing that.
  Reply
#2
Hello Alex,

which container are you loading? Is there an example for us to reconstruct and to load from here?

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
I've tried 
netpi-nodered-npix-rs232
hilschernetpi/netpi-nodered
hilschernetpi/netpi-desktop-hdmi
nodered/node-red-docker

some of them i could installed but then they got stuck in state "created" and some of them i couldn't install.
the only one i was able to install and run was the opc-ua container.
I have deleted all the dockers to make sure they do not interfere with one another.

I hope this answers your question
  Reply
#4
There is one more question. In netPI's web GUI default landing page you see in the lower right corner the software version you are using. Are you already using V1.1.6.0?
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#5
Hi,

the SW version is V1.1.0.0
  Reply
#6
Hi Alex,

please update to the latest software version V1.1.6.0. You can find the download here: https://www.netiot.com/netpi/industrial-raspberry-pi-3/
This version brings, among other things, a extended timeout value. This is important e.g. to pull large images.

Best Regars
Patrick
  Reply
#7
Ok, thank you very much for the support. will udpate on how it goes.
  Reply
#8
Thank's a lot for your support, I updated the FW and everything works now.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  USB camera issues dcatteeu 9 39 Yesterday, 01:54 PM
Last Post: Armin@netPI
Information netPI Docker REST API for versions >= V1.1.4.0 Patrick@netPI 1 69 July-16th-2019, 02:45 PM
Last Post: Patrick@netPI
  [SOLVED] Pull Docker Image a.w.d.m. 8 37 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  docker timing MGharat 2 34 June-13th-2019, 08:57 AM
Last Post: Patrick@netPI
  Launching multi-containers at a time - Docker stacks Armin@netPI 0 21 June-4th-2019, 04:11 PM
Last Post: Armin@netPI
  [INFO]Docker DNS server Armin@netPI 0 19 March-7th-2019, 09:02 AM
Last Post: Armin@netPI
  [SOLVED] node-red Dashboard Docker Image for netPI? anrodriguez 1 23 February-7th-2019, 05:35 PM
Last Post: Armin@netPI
  Setup trusted Docker registry on a Raspberry Pi to host netPI containers Armin@netPI 12 652 January-31st-2019, 06:47 PM
Last Post: Armin@netPI
  [SOLVED] Keep getting a message that session expired in Docker SteveO 2 41 January-24th-2019, 11:50 AM
Last Post: Armin@netPI
  [SOLVED] Running Eclipse inside Docker Rahulsagar 6 52 January-21st-2019, 04:03 PM
Last Post: Rahulsagar

Forum Jump:


Users browsing this thread: 1 Guest(s)