• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Docker issues

I'm having trouble installing new containers on my NetPI RTE plarform.
I'm getting errors such as 
"Unexpected token < in JSON at positions 1"


"Cannot read property 'replace' of null

It keeps on happening with different containers but sometimes the installation is successful.
I am following your installation instructions exactly. 

Appreciate your help on this.


In addition i have constant red LED set on the NetPI (Err NS) I'm not sure if this is related but i'm wondering what is causing that.
Hello Alex,

which container are you loading? Is there an example for us to reconstruct and to load from here?

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

I've tried 

some of them i could installed but then they got stuck in state "created" and some of them i couldn't install.
the only one i was able to install and run was the opc-ua container.
I have deleted all the dockers to make sure they do not interfere with one another.

I hope this answers your question
There is one more question. In netPI's web GUI default landing page you see in the lower right corner the software version you are using. Are you already using V1.1.6.0?
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


the SW version is V1.1.0.0
Hi Alex,

please update to the latest software version V1.1.6.0. You can find the download here: https://www.netiot.com/netpi/industrial-raspberry-pi-3/
This version brings, among other things, a extended timeout value. This is important e.g. to pull large images.

Best Regars
Ok, thank you very much for the support. will udpate on how it goes.
Thank's a lot for your support, I updated the FW and everything works now.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Docker amd64 instead of arm biancode 3 85 January-17th-2021, 09:40 PM
Last Post: Armin@netPI
  docker.service start failed EUROKEY 13 1,020 January-17th-2021, 07:52 PM
Last Post: Armin@netPI
  NPIX-4DI4DO and NetPi-Nodered container issues alhammi 4 400 November-16th-2020, 01:35 PM
Last Post: alhammi
  Network issues after upgrading to Stretch + kernel to 5.4 carmel85 2 445 July-28th-2020, 03:04 PM
Last Post: Armin@netPI
  Docker cannot find image COswald 16 1,109 May-18th-2020, 07:15 AM
Last Post: COswald
  After „Rebuild“ of Docker neither the node-RED nor the dashboard can be accessed MAK 4 812 January-31st-2020, 02:14 PM
Last Post: MAK
  [SOLVED] Docker GUI login issue MGharat 1 478 September-19th-2019, 11:50 AM
Last Post: Armin@netPI
  USB camera issues dcatteeu 9 1,015 September-16th-2019, 01:54 PM
Last Post: Armin@netPI
Information netPI Docker REST API patrick 1 608 July-16th-2019, 02:45 PM
Last Post: patrick
  [SOLVED] Pull Docker Image a.w.d.m. 8 723 July-8th-2019, 11:17 AM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)