• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using SSH in netPI-nodered-fieldbus image
#1
Adding the SSH portion from the https://github.com/Hilscher/netPI-contai...nvironment into the https://github.com/Hilscher/netPI-nodered-fieldbus image I was able to have access to the image.

Doing the same with the latest netPI-nodered-fieldbus image, the password does not get accepted. Could someone please have a look what I am doing wrong.
https://hub.docker.com/r/schranz/netpi-n...v6pmnnfkz/

The build log says something invoke-rc.d: policy-rc.d denied execution of start.I am totaly lost.
  Reply
#2
The error is easy to explain:

if you look to our image https://hub.docker.com/r/hilschernetpi/n...n-stretch/, you see the Docker file uses this line which is made for Debian stretch

&& sed -i 's/#PermitRootLogin prohibit-password/PermitRootLogin yes/' /etc/ssh/sshd_config \

you are using the line for debian:jessie

&& sed -i 's/PermitRootLogin without-password/PermitRootLogin yes/' /etc/ssh/sshd_config \

The sshd_config file has been change from one debian OS to the other using "prohibit-password" instead of "without-password".

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Thank you very much. Does work again.
  Reply
#4
Still you should not rely on Docker Hub service only to build images remotely on the web. You need definitively a Raspberry Pi 3 to make developments yourself locally right in front of your screen. Only with a Pi 3 you have possibilities for debugging.

There will be definitively a certain point where the netPI supports ends from the forum's point of view. In detail if users build their very own container image where non of us has a clue what have been compiled together.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NPIX-4DI4DO and NetPi-Nodered container issues alhammi 4 398 November-16th-2020, 01:35 PM
Last Post: alhammi
  Internet on the fieldbus-side COswald 2 210 October-19th-2020, 01:40 PM
Last Post: COswald
  NodeRed and EtherCAT Schranz 3 757 September-23rd-2020, 08:01 AM
Last Post: Armin@netPI
  Receive at startup additional data through the Fieldbus Port Schranz 1 296 September-10th-2020, 10:55 AM
Last Post: Armin@netPI
  Fieldbus Ports not working Schoko 13 1,178 June-29th-2020, 09:43 PM
Last Post: Armin@netPI
  Docker cannot find image COswald 16 1,040 May-18th-2020, 07:15 AM
Last Post: COswald
  PHP-Apache Image hsammer 3 359 March-12th-2020, 05:23 PM
Last Post: hsammer
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 733 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 797 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 661 August-20th-2019, 07:22 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)