• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Internet on the fieldbus-side
#21
Hello Carsten,

I have tested the "LANEnabler" container for cifX0 in the version 1.1.3 successfully on my ...TPI... device . I am able to ping the cifX0 from a remote station that is in the same IP subnet and also I am able to ping the remote station from insider the cifX0 container. I used the same setup as you have configured and set the cifX0 IP address during my test to value 192.168.1.111 while the remote station was conifgured to 192.168.1.1.

The README of the containers https://registry.hub.docker.com/r/hilsch...ernet-lan/ says: "After a change a container restart is necessary while no Ethernet cable is plugged into this interface.". This means the driver needs at least one restart. I did it very simple: I just removed the power of my device and let it boot again ... and right after that I was able to ping the devices.

The changes from 1.1.1 to 1.1.2 was just a README text change. The change from 1.1.2 to 1.1.3 was simple a check if on ...TPI... devices the cifX0 was created already by Node-RED that the container does not start the cifX0 in another instance to avoid a collision. So also this change has no influence on the container's core function.

Right now I have no explanation why 1.1.1 works and 1.1.3 not. You should try to repower your device as I did.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#22
Hello Armin,

many thanks for Your reply and test. 
I have read the README also, and to be sure, I have properly shutdown the device. All with no effect. 

I will try an update from 1.1.1 to 1.1.3. If this works, maybe where is something remaining from the older version.

What I don't want to do with this box, is to facory reset it. Because the TOSIBOX for CONTAINER is now licensed and matched to our Keys.

CU here later,

Carsten
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NetPI WiFi through Internet DSongra 1 2,069 September-7th-2021, 07:54 AM
Last Post: Armin@netPI
  2 MAC addresses for fieldbus RJ45 ports tad 2 2,287 March-11th-2021, 01:17 PM
Last Post: tad
  Receive at startup additional data through the Fieldbus Port Schranz 1 2,969 September-10th-2020, 10:55 AM
Last Post: Armin@netPI
  Fieldbus Ports not working Schoko 13 9,221 June-29th-2020, 09:43 PM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 5,077 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 5,426 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 4,263 August-20th-2019, 07:22 AM
Last Post: Armin@netPI
  [SOLVED] WebConfig netpi-nodered-fieldbus JohnyD94 13 8,602 May-6th-2019, 12:20 AM
Last Post: JohnyD94
  [SOLVED] hilschernetpi/netpi-nodered-fieldbus Fieldbus configurator can't be open Andreas 6 6,050 June-11th-2018, 09:12 AM
Last Post: Armin@netPI
  fieldbus in error Schranz 7 4,911 March-13th-2018, 07:28 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)