• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Faulty devices description file from Github

in order to run an example program / container over the NetPi on the Profinet fieldbus system via the image "hilschernetpi/netpi-netx-programming-examples" I downloaded the corresponding device description file from GitHub / electronic-data-sheets following the instructions on DockerHub.

This is however faulty. When opening the file via an texteditor, parsing Errors are displayed and the device description file can not be imported into the Simatic Manager because it seems to be faulty. Furthermore a .bmp and a .ico file are available on github. These too are not able to open after download.

Now my question:
Is there a more up-to-date working device description file on another website?

I would very much welcome further solutions.

Thank you and best regards

I downloaded the whole source code from github as zip file.


Then I extracted the whole software package it with 7-zip and imported it to my TIA V15 software.


After that I found the device in the TIA portal device catalogue as usual and I was able to place device next to my PLC:


Everthing works fine as expected.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

thank you very much,

this one seems to work.

However, I have another problem with the netpi in my fieldbus system.
I can not find the netpi in my simatic manager to set up a connection and configure it.
Even after I started the container hilschernetpi / netpi-netx-programming-examples and installed the driver and the Profinet firmware, no connection was possible.

Do you have a suggestion or an idea why I can not find the netpi on the network?

Does the fieldbus port have to be activated or configured in Netpi manager? The only network interface that I can configure in LAN is the Ethernet interface.

best regards

there is no need for any port setting in netPI Web-GUI all is done in the container. You said you have started ./PNS_simpleConfig program successfully. This executeable is providing all necessary settings that netPI and its fieldbus ports are operating as PROFINET IO device. There are no other settings to be done, just starting this program is enough.

When you connect your S7-PLC to any of netPI's RJ45 fieldbus ports. Do you see LINK and ACT LED flashing and activated on this RJ45 port? If so then there is a physical connection first of all.

Aa next I don't know how familiar you are with PROFINET, but on PROFINET the devices are ALL addressed by unique names. Have you completely read the Containers README? There is a chapter "Protocol specifics". Please read it and follow the link. It explains that a fresh netPI needs a PROFINET name and you have to set it with your TIA portal software. Only then a S7 PLC is able to find netPI on the network. Have you set the name?
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Did everything as recommended but unfortunately I did not keep the program running. Now I was able to build a connection to my netpi while the program is running in the background. So for the moment everything works fine.

Thanks again for your fast and helpful response.
Yes indeed, the program needs to run. It exchanges the process data with the console and netPI's PROFINET buffer and signals the netPI that an application is running and also triggers the watchdog function. If you stop the program, it signals to netPI to stop the PROFINET communication.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads…
Thread Author Replies Views Last Post
  cannot execute file: Exec format error - NETPI tuliosouza 1 2,018 January-13th-2022, 01:17 PM
Last Post: Armin@netPI
  GSDML File royazriel 6 7,624 October-7th-2020, 08:39 PM
Last Post: Armin@netPI
  GSDML file milesie 2 5,245 February-18th-2020, 05:18 PM
Last Post: Armin@netPI
  file folder with netPI RTE MGharat 1 2,376 December-5th-2019, 07:04 AM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 4,436 August-20th-2019, 07:22 AM
Last Post: Armin@netPI
  [SOLVED] How to update firmware philippbruhin.ch 12 10,351 July-16th-2019, 11:20 AM
Last Post: patrick
  [SOLVED] Docker issues AlexRegev 7 5,802 June-26th-2019, 02:14 PM
Last Post: AlexRegev
  Static mapping of USB-devices deme 11 10,602 May-15th-2019, 04:02 PM
Last Post: Armin@netPI
  [SOLVED] Diagnostic service MGharat 1 2,174 April-2nd-2019, 09:45 PM
Last Post: Armin@netPI
  [SOLVED] NPIX-DIDO MGharat 2 6,941 March-13th-2019, 06:06 AM
Last Post: MGharat

Forum Jump:

Users browsing this thread: 1 Guest(s)