• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fieldbus Ports not working
#11
By factory default the netX controller chip is loaded with PROFINET slave software. And if noone (your application) configures it the LED is indeed red or is flashing red if you simple connect an Ethernet cable to any of the two RTE ports.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#12
(June-29th-2020, 03:05 PM)Armin@netPI Wrote: Which firmware did you load into the netX controller that is assembled on the NIOT-E-NPI3-51-EN-RE board additionally?

Hi Armin,

I'm confused, what additional software do I need. If I recall I always had the NS ERR LED. Can you advise what additional firmware is required?

regards,

Duncan.
  Reply
#13
You need to load the container https://github.com/HilscherAutomation/ne...hernet-lan. This turns the netX controller chip into a standard TCP/IP controller. Then you can configure this interface named cifx0 like your primary port eth0.

Look to this post for example https://forum.hilscher.com/Thread-RTE3-U...-interface

or this post https://forum.hilscher.com/Thread-Modbus...ernet-Port
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#14
I just have seen that I posted a wrong link. This is the container you have to load.

https://hub.docker.com/r/hilschernetpi/n...ernet-lan/

For a very easy configuration I recommend to run it in "Host" mode always. This is the easiest way to get the netX running as TCP/IP network interface.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Profinet stopped working (spidev spi0.0: SPI transfer timed out) Schranz 7 574 November-2nd-2020, 04:20 PM
Last Post: Armin@netPI
  Internet on the fieldbus-side COswald 2 214 October-19th-2020, 01:40 PM
Last Post: COswald
  Receive at startup additional data through the Fieldbus Port Schranz 1 307 September-10th-2020, 10:55 AM
Last Post: Armin@netPI
  DHCP server not working m-yoshikawa 20 1,656 August-27th-2020, 01:30 PM
Last Post: ioexpert
  Node-Red "http in"-Node not working DWxPro 8 856 June-19th-2020, 01:12 AM
Last Post: DWxPro
  Node Red stop working DSongra 1 509 February-12th-2020, 08:19 AM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 749 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 810 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 675 August-20th-2019, 07:22 AM
Last Post: Armin@netPI
  [SOLVED] netPI stops working (502 - Bad Gateway) Andi 3 504 June-19th-2019, 03:58 PM
Last Post: Andi

Forum Jump:


Users browsing this thread: 1 Guest(s)