• 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setup trusted Docker registry on a Raspberry Pi to host netPI containers
How to setup an own trusted Docker Registry Server (comes as a container from Docker Hub) to push and pull Docker images to and from.

As example a standard Raspberry Pi (RPi) preloaded with Raspbian OS is used but you can be any Linux Host:

Make a basic setup of your RPi:

  1. Get terminal access to the system using a tool like putty
  2. Change to user root
    $ sudo -i
  3. Install Docker Engine
    $ curl -sSL https://get.docker.com | sh
  4. Give your RPi a reasonable Hostname e.g. myregistry. (The name has to be lowercase since Docker can address image/tags/registries by name only if they are lowercase. A discrete Hostname is necessary since it is strongly recommended that trusted CA certificates identifiying a device as secure should not be issued for the device's IP address but for its Hostname instead.) Use an editor (e.g.nano) to change the current Hostname raspberrypi to myregistry in the two files:
    $ nano /etc/hosts (string behind the ip address
    $ nano /etc/hostname

  5. (optional) If you want to make the Hostname public in a MS Windows based office network you have to install two additional services
    $ apt-get install samba
    $ apt-get install winbind

    Additionally the wins service needs to be activated. Edit the following file in an editor
    $ nano /etc/nsswitch.conf[/b]
    In the line hosts: add the term wins and mdns4 to the existing terms files, dns, mdns4_minimal and others
  6. Reboot the system
    $ reboot now
  7. After the reboot generate new SSH keys pairs. First remove old ones
    $ rm /etc/ssh/ssh_host_*
  8. Reconfigure SSH server and generate new key pairs
    $ dpkg-reconfigure openssh-server
  9. Restart SSH server
    $ service ssh restart
Generate a self signed certificate with help of an own CA(Certificate Authority):

  1. Create a folder certs on your RPi host and move to it. This folder is mapped later into the Registry Server container using the Docker "volume mapping" parameter allowing to mirror a host folder in a container when it is started. So this folder serves as storage for the needed keys and certicates for the container.
    $ mkdir -p /certs && cd /certs
  2. Generate a new key devdockerCA.key needed for your own "trusted" CA used as private key.
    $ openssl genrsa -out devdockerCA.key 2048
  3. Generate public certificate of your CA devdockerCA.pem derived from the private key. Adjust the following sample configuration "/C=DE/ST=Hessen ..." to your personal credentials. The devdockerCA.pem file made known on your RPi host lets it accept certificates signed by this CA, respectively the one reported by your Registry Server later.
    $ openssl req -x509 -new -nodes -key devdockerCA.key -days 10000 -out devdockerCA.pem -subj "/C=DE/ST=Hessen/L=Hattersheim/O=Hilscher/OU=Hilscher/CN=myownca/emailAddress=myownca@hilscher.com"
  4. For your Registry Server another key named domain.key needs to be generated that is used as public key and needs later to be signed by your CA.
    $ openssl genrsa -out domain.key 2048
  5. Create a configuration file req.conf with
    $ nano /certs/req.conf
    that necessary for a proper signing procedure. Copy the following content to it and tailored it to your credentials. Especially the CN parameter Common Name has to match your choosen RPi Hostname):
    [ req ]
    distinguished_name = req_distinguished_name
    req_extensions = v3_req
    prompt = no
    [ req_distinguished_name ]
    C = DE
    ST = Hessen
    L = Hattersheim
    O = Hilscher
    OU = netIOT
    CN = myregistry
    emailAddress = mypi@hilscher.com
    [ v3_req ]
    keyUsage = keyEncipherment, dataEncipherment
    extendedKeyUsage = serverAuth
    subjectAltName = @alt_names
    [ req_ext ]
    subjectAltName = @alt_names
    [ alt_names ]
    DNS.1 = myregistry
    DNS.2 = myregistry.local
    DNS.3 = myregistry.domain
    IP.1 =

  6. Generate now a CSR (Certificate Signing Request) including the public Registry Server key intended to be signed by your CA.
    $ openssl req -new -key domain.key -out dev-docker-registry.com.csr -config req.conf
  7. Cross sign your Registry Server public key with the private CA merged with the CSR parameters and generate domain.crt file which is the final signed certificate of your Registry Server.
    $ openssl x509 -req -in dev-docker-registry.com.csr -CA devdockerCA.pem -CAkey devdockerCA.key -CAcreateserial -out domain.crt -days 10000 -extensions req_ext -extfile req.conf
  8. Let the public CA certificate become known on your RPi (else pushing to the Registry Server from the local RPi itself (later topic) will fail).
    $ cp /certs/devdockerCA.pem /usr/local/share/ca-certificates/devdockerCA.crt
    $ update-ca-certificates
    $ reboot now

  9. Start the Registry as a container (certs folder is mapped to it)
    $ docker run -d --restart=always --name registry -v /certs:/certs -e REGISTRY_HTTP_TLS_CERTIFICATE=/certs/domain.crt -e REGISTRY_HTTP_TLS_KEY=/certs/domain.key -p 443:5000 registry:2
  10. Check if the Registry Server is running
    $ curl https://myregistry.local/v2/_catalog
    {"repositories":[]} -> returns empty list of repositories, which is fine.
Load a test image on your Registry:

  1. Pull a valid image from the Docker Hub internet registry on your RPi
    $ docker pull nginx:latest

  2. Tag the image with a name fitting to the name of your registry to prepare it for a push
    $ docker tag nginx:latest  myregistry.local/mytest:latest

  3. Push the tagged image to your registry
    $ docker push myregistry.local/mytest:latest

Make the certificate known on your netPI:

  1. Copy the previously created /certs/devdockerCA.pem file from your RPi to a location where it can be uploaded over netPI's Web-GUI.Typically you would use an FTP client such as WinSCP to copy it to your PC/machine running the web browser.
  2. Upload the pem file to your netPI using the Security/Public Key Infrastructure menu, highlighting then Trusted Certification Authorities and clicking upload finally as the picture shows:
  3. Reboot the netPI to let the new trusted CA become known on your netPI
Have a look on this video tutorial on Youtube:

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


i followed this setup using a netIoT not a netPi. Everything went fine until i uploaded the certificate with net Web-GuI.

After the restart i cannot connect to the netIoT via Wifi or cable using the static ip port or the dhcp port i allways get a time out for the static ip and a not found error for the dhcp.
(November-2nd-2018, 10:04 AM)PhilippS Wrote: i followed this setup using a netIoT not a netPi

You mean you bought a NIOT-E-TPI Edge Gateway instead of a netPI? Is my understanding correct?

This one?: https://www.hilscher.com/products/produc...eeis/?cats=
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


we are using this gateway: https://www.hilscher.com/products/produc...-gb-reeis/?

the registry is running on standart raspberry pi.
Hello Philipp,

 ... but your problem is not the Raspberry registry - which is running fine as I have understood -, your problem is the NIOT-E-TIJCX-GB-RE is not running fine any more, correct?

You said, you used the *.pem file and have imported it into your NIOT-E-TIJCX-GB-RE device and after you did that, the device was not responding any more and you cannot reach the Web GUI any more, correct? Or when did the problem started to occur?

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hi armin,

yes I have the registry running on the Raspberry pi.

Everything went fine until step 3 in Work on your netPI.

I uploded the *.pem using the WebGUI and issued a reboot.
After the reboot I could not reconnect to the Gateway.

I connected directly to the Gateway using a cable.
I tried both ports. I am not able to connect to the Gatway GUI anymore.

If I try to connect via Port 1 using the dchp server I get a Webpage not found error in the browser.
If I try to connect via Port 2 using a static IP connecting to the static IP of the Port I get a timeout.

I tried pinging the device via powershell and got a timeout.
Ok Philipp, understood your problem.

Basically it seems you did everything well. I couldn't do it better. The *.pem file should never cause the NIOT Edge Gateway causing a boot failure in my opinion.

Since Edge Gateways are not supported through this forum but through Hilscher Hotline, please send your *.pem file and your inquiry to hotline@hilscher.com. They will take care of it.

One thing in addition. The edge gateway your are using is a x86 intel process based device. All netPI Docker containers will not on this Edge Gateway machine. But I agree that a registry can run on any machine, also on a Raspberry, and host ARM based and x86 based container images.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

By the way ... if the device is not responding any more as you describe ... the only way to recover it from this state is to reset it to factory default using a USB stick and the latest firmware from here https://www.hilscher.com/de/support/downloads/ on it
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hallo Armin,
we have setup a registry wihin our company which is available by the hostname docker01 and it ist working from any Raspberry Pi.

If we try to pull images from the Portainer Site on the NetPi we always get the same error:

Failure Get https://docker01.local/v2/: dial tcp:lookup docker01.local: no such host

I can ping the server from inside a Container on the NetPi, so I think the network settings on the NetPi are correct (DHCP).

In the syslog i can see following lines. I guess the netpi uses the google dns server only

<30>1 2019-01-31T10:12:56+00:00 NTB827EBEADCB9 dockerd 1463 - - time="2019-01-31T10:12:56.012225733Z" level=info msg="No non-localhost DNS nameservers are left in resolv.conf. Using default external servers: [nameserver nameserver]"

<30>1 2019-01-31T10:16:24+00:00 NTB827EBEADCB9 dockerd 1463 - - time="2019-01-31T10:16:24.722309664Z" level=info msg="No non-localhost DNS nameservers are left in resolv.conf. Using default external servers: [nameserver nameserver]"

Do you have any idea what is happening here.

Best Regards
Which version of netPI do you use? Versions >= So if yes, do you have defined your server as a registry right?

The error indicates to me that the name "docker01.local" cannot be resolved by your DHCP server. How about using a registry with the name" docker01" without ".local" and if nothing else works just enter the plain ip address instead of "docker01.local" for test purposesy, then resolving names it not necessary at all.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads…
Thread Author Replies Views Last Post
  https certificate issues in new nodered docker image Dipro 1 1,809 May-4th-2022, 05:46 AM
Last Post: Armin@netPI
  Portainer Stack fails to pull from private Registry Andi 5 5,888 February-16th-2022, 09:03 AM
Last Post: Armin@netPI
  Initial Setup of Control Panel with admin + admin thorws error Michi 4 2,996 January-28th-2022, 09:28 AM
Last Post: Michi
  Docker exposed port don't send data on eth0 COswald 3 3,327 July-15th-2021, 02:10 PM
Last Post: Armin@netPI
  Docker not enabled tad 10 5,194 July-14th-2021, 08:54 AM
Last Post: Armin@netPI
  netPI setup procedure tad 1 2,196 March-15th-2021, 05:48 AM
Last Post: Armin@netPI
  Docker amd64 instead of arm biancode 3 3,214 January-17th-2021, 09:40 PM
Last Post: Armin@netPI
  docker.service start failed EUROKEY 13 9,766 January-17th-2021, 07:52 PM
Last Post: Armin@netPI
  Get host MAC via REST API inside container bschandra 4 3,875 November-16th-2020, 09:26 AM
Last Post: bschandra
  netpi raspberry Hochschulstudent 1 2,442 August-12th-2020, 01:50 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 3 Guest(s)