• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Communication between PLC and Netpi
Dear Hilscher team

We are building a prototype to send gathered information from a S7 1500 PLC to netpi via Profinet.
The connection seems to work, both the PLC and the fieldbus node don’t show any error.
For first test we set up an output address (1 Byte) in the PLC and assign the first bit with a switch conntected to the PLC. But the information received with the fieldbus node never displayed the information sent and additionally the information read from the fieldbus node switches each time between 2 different values. We stopped sending from the PLC but the fieldbus node kept reading 2 different values. Then we tried to send one Byte to the PLC but it probably never came through, the fieldbus input node then stated 2 different values but still switching as mentioned before.
I have the feeling we are just missing some detail but we are struggling to find it.

Attached you can find some screenshots regarding the PLC and Netpi settings

Best regards

Attached Files
.pdf   attachment.pdf (Size: 856.08 KB / Downloads: 6)
Hi Michael,

I have an S7 1500 PLC here myself. So I can make tests on my own to see what happens.

But let me repeat what I have understood. You are using Node-RED to configure the netPI device, correct? Which version of Container/Node-REDare you using? The latest version from here https://hub.docker.com/repository/docker...pi-nodered ?

Then to your configuration. So say you configured one output ... but later you describe you have also an input ... what is now correct? How many inputs and outputs repectively send and receive data bytes have you configured not finally?

If you say you set one single bit ... this make value 0 and 1 for me in best case. This value you sent through PLC to the netPI device and fieldbus node input node ... but which value do you see? So say you see two values ... which values.

Also please send my you Node-RED flow using the export function embedded in Node-RED so I can see what you are doing on Node-RED side.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hi Armin,

thanks for your quick answer.

Here is the requested info:
The version of NodeRed is HILSCHERNETPI_NODERED_FB_VERSION 1.2.0

For both input and output we configured 1 byte on the plc and the WebConfigurator in NodeRed. To comunicate we just set one bit in the output byte and try to receive the byte with the fieldbus node (signal 0000 0001).
The signal which we actually received was not 0000 0001. We received different signals, and when we tried to send a signal to the PLC we had one bit changed in the receiving signal. For example, we receive 1001 1111 and upon sending a signal from NodeRed we received 1011 1111 once, so just one bit changed. After we stopped we received the inital signal 1001 1111.
Some tryouts later while still trying to receive data, we injected with the fieldbus node 1 byte to the plc and the received data changed (e.g. 1000 1111 to 1010 1111)

Attached the asked exported Node-RED flow

Thank in advance


Attached Files
.txt   test_flow_michael.json.txt (Size: 2.13 KB / Downloads: 6)
The problem has been identified ... new container version V1.2.2 is ready for pulling.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

(September-9th-2020, 04:49 PM)Armin@netPI Wrote: The problem has been identified ... new container version V1.2.2 is ready for pulling.

It worked. The update solved our issues.
Thanks for the support

Possibly Related Threads…
Thread Author Replies Views Last Post
  REST API server data communication MGharat 2 2,713 July-21st-2021, 07:01 AM
Last Post: MGharat
  communication cycle as EtherCAT slave tad 2 2,408 April-20th-2021, 11:14 AM
Last Post: tad
  OPC UA communication - Cloud Stefano.sotelo 1 2,765 April-26th-2018, 10:21 AM
Last Post: Armin@netPI
  Inter-container communication with help of DNS Armin@netPI 0 2,279 December-4th-2017, 07:02 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)