• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Send Data to Specific Port via UDP

I connected the netPi RTE 3 to a Raspberry Pi 3 B+ via LAN. I switched off DHCP and assigned a fixed IP address.
In order to send data to the netPI, I want to use UDP with Node-RED. I noticed, that Armin already posted the default UDP-Ports that the netPI listens to (see below), but I want the Port to be 9323. For this, I built up a Flow addressing the local IP of the netPI on Port 9323.
The "Listening"-Flow is running on the netPI and the "Sending"-Flow is running on the Raspberry Pi (See attachment).

The connection between them seems to be woking since I am able to Ping the netPi-IP-Address. But when I try to send messages to the mentioned Port 9323 nothing happens. Do I have to change some settings in the netPI's UI to allow listening to other Ports as well or is there another mistake I made?

Many thanks in advance,


(February-9th-2018, 01:36 PM)Armin@netPI Wrote: By default netPI listens to the following ports:

  • Port 80,nginx -> web server / reverse proxy
  • Port 443,nginx -> web server / reverse proxy
  • Port 49152, upnpd -> UPnP daemon
  • 123,ntpd -> Network Time Protocol daemon
  • 137,nbnsd -> Netbios Name Service
  • 1900, upnpd -> UPnP daemon
  • 5353, avahi-daemon -> Zeroconf
  • 60843, avahi-daemon -> Zeroconf temporary port
  • 36517, avahi-daemon -> Zeroconf temporary port
  • 41429, dnsmasq -> DNS proxy temporary port

Attached Files
.txt   Flow_netPI.txt (Size: 427 bytes / Downloads: 2)
.txt   Flow_RaspPi.txt (Size: 1.18 KB / Downloads: 0)
In Docker listing ports needs to be exclusively enabled for each container. This has nothing to do with netPI.

If you Node-RED container is running in bridged mode - and I suppose it is - you have to use the "port mapping" function in Docker web-UI to map the external netPI host port 9323 to the container internal 9323 port and then the data is forwared to Node-RED that is running inside the container.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hello Armin,

I just tried it and it works just fine. Thank you very much for your quick help!

Kind regards,


Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Storing data on a (remote) database MGharat 20 20,969 June-13th-2022, 03:05 PM
Last Post: Armin@netPI
  Read/write data from S7 with netPI over Profinet student 10 9,659 September-9th-2020, 04:59 PM
Last Post: Armin@netPI
  PROFINET to OPC UA data conversion with Node-RED Armin@netPI 0 3,552 July-7th-2020, 12:20 PM
Last Post: Armin@netPI
  Getting data from AllenBradley PLC MarcoMedina 3 4,142 February-26th-2020, 11:53 AM
Last Post: Armin@netPI
  Fetch data from S7 PLC Profibus DP MGharat 3 3,766 March-14th-2019, 11:21 AM
Last Post: Armin@netPI
  IBM sensor data historian and analytics engine for the netPi AlexKoeMuc 0 2,318 November-28th-2017, 01:39 PM
Last Post: AlexKoeMuc

Forum Jump:

Users browsing this thread: 1 Guest(s)