• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Activate Projects Feature in NodeRed

I currently have a container running made from the image hilschernetpi/netpi-nodered-fieldbus:latest. It has node-red installed and I can perfectly access it. On the other hand, I know that there is a feature in node-red to create projects and one just have to modify the node-red settings file.

So my question is, is there any way I could access that file and modify it in a node-red within netPI?

Thank you in advance.
Regards, Alex
Hello Alex,

I know this feature of node-red you are speaking about and also if you follow this topic here https://nodered.org/docs/user-guide/projects/ you have to edit the settings.js file.

There are two ways:

1.) You make your own container were you add the edits into the settings.js yourself and then use your own container instead of our example container or
2.) You are using the fieldbus container from us like it comes and click to the container's Name in the container overview list and then >_Console and a web console will instantly open. This console jumps into the container and you can call commands in the container. Install a editor like nano with apt-get update and apt-get install nano and then edit the settings file nano /root/.node-red/settings.js.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Thank you very much. I appreciate the help


Possibly Related Threads…
Thread Author Replies Views Last Post
  NPIX-4DI4DO and NetPi-Nodered container issues alhammi 4 399 November-16th-2020, 01:35 PM
Last Post: alhammi
  NodeRed and EtherCAT Schranz 3 774 September-23rd-2020, 08:01 AM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 749 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  [SOLVED] WebConfig netpi-nodered-fieldbus JohnyD94 13 1,092 May-6th-2019, 12:20 AM
Last Post: JohnyD94
  [SOLVED] nodered : flows_localhost deleted after creating an image from container paubau 6 651 September-21st-2018, 10:19 AM
Last Post: paubau
  [SOLVED] hilschernetpi/netpi-nodered-fieldbus Fieldbus configurator can't be open Andreas 6 889 June-11th-2018, 09:12 AM
Last Post: Armin@netPI
  NodeRed Modbus Flow iotuser 1 350 March-27th-2018, 11:14 AM
Last Post: Armin@netPI
  Using SSH in netPI-nodered-fieldbus image Schranz 3 601 March-6th-2018, 06:29 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)