• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Portainer does not start container

I´m trying to start a container on Portainer, but I get the ERROR message "No such image: hilschernetpi/example : latest".
I followed the whole instructions on hub.docker.com, but it does not work.
Maybe their is an Internet problem?
I connected my netPI to a hotspot from my phone to get Internet access so I can pull images. How can I check if I have Internet access. I only can see that the netPI is connected.

Thanks in advance
Two things have been discussed very often:

1.) First of all make sure you set the system time correctly (manually or via NTP). Else time differences between netPI's system time and the DockerHub time prevents loading an image
2.) Pulling from Docker Hub goes across port 5000. If you are behind a firewall not allowing a pull across port 5000 then pulling an image will not work. I had this case already recognized by on of the netPI user. After he released the port 5000, everything worked fine
3.) make sure you have written the image you want to pull correctly: for example I don't know the image "hilschernetpi/example : latest" you are referring to as well. So for me "No such image" is correct in my eyes. I know an image "hilschernetpi/netpi-nodered-fieldbus" for example.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

I have also ran into this issue (after setting the time, checking for port 5000 and copy/paste from the readme).

I was able to start the container only after I went to /portainer/#/images/ and pulled the image before attempting to create/start the container.

Is that correct, or should you be able to create a container without a local image? Is there a timeout issue with pulling the image when creating the container?

Thank you
Hi Steve,

pulling the image on a Raspberry Pi 3B CPU (on netPI then also) takes longer than on other CPUs. This is because of the bottleneck (serial interface) between the CPU and the SD card used as memory storage and the small cache the CPU owns. Also it depends on the traffic that is ongoing on Docker hub, if you pull an image from there. Then also it has influences if you have Containers actively running already and of course it depends on how big your image is. All those parameters influence the Container load time.

Additionally I have a remark that since firmware we improved the load time by removing a permanent logging of internal Docker messages. Please verify that you have this firmware or higher actively running on your netPI.

If you want to get rid of depencencies from Docker Hub, I recommend to set up a local registry anyway. Then at least this timing is constant.

And if I would summarize my experience till today I would say that seeing this timeout is rare and that starting a container with implicit pull works in 95% of all cases. The timeout is not caused by Docker running on netPI by the way, but due to a Web-Browser <-> portainer.io timeout.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads…
Thread Author Replies Views Last Post
  Portainer Stack fails to pull from private Registry Andi 5 6,522 February-16th-2022, 09:03 AM
Last Post: Armin@netPI
  Start Up Queries yongzhi 3 2,635 July-20th-2021, 11:50 AM
Last Post: Armin@netPI
  TOSILOCK for CONTAINER COswald 3 2,621 July-13th-2021, 11:32 AM
Last Post: Armin@netPI
  Access to RTC from my own container application tad 1 3,855 March-19th-2021, 02:58 PM
Last Post: Armin@netPI
  [SOLVED] Starting services/commands/scripts at startup of a container Jonas.Sellmann@outlook.de 9 7,187 March-9th-2021, 08:47 AM
Last Post: WalterSchaefer
  Portainer password reset r.nilles 1 2,857 January-25th-2021, 11:12 AM
Last Post: Armin@netPI
  docker.service start failed EUROKEY 13 10,471 January-17th-2021, 07:52 PM
Last Post: Armin@netPI
  OpenVPN container Armin@netPI 0 1,838 January-3rd-2021, 12:13 PM
Last Post: Armin@netPI
  operating Console of a container on netPI connected to Wi-Fi tethering tad 3 3,023 December-3rd-2020, 12:32 PM
Last Post: tad
  NIOT-E-NPIX-4DI4DO with netpi-netx container WalterSchaefer 3 7,807 November-25th-2020, 01:06 PM
Last Post: zen89

Forum Jump:

Users browsing this thread: 1 Guest(s)