• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hdmi not working
#11
(February-25th-2022, 09:31 AM)Armin@netPI Wrote: Hello,

what do you mean with HDMI - VGA? Do you mean you are using an adaptor between the netPI HDMI port and your monitor?

Whenver you switch on any Raspberry Pi or netPI in the whole world independent if any USB device is connected or not the graphics controller of the Raspberry Pi will always make a self test and showing for 1/2 second a colored picture of 16Mio colors in the case it has found a boot image on the SD card. If not any bootable image was found by any reason then the HDMI port remains black all the time.

HDMI and USB are driven on the PCB board by totally independent chips. USB is supported by an external controller that sits next to the Raspberry Pi CPU. If you say there are influences whether or not you put load on USB this sounds to me like there is a relation in between and there is a depencency on the somehow im the power supply circuit of the board. But this is all speculation.

Thx
Armin

Yes, its an hdmi - vga adapter.

I can see the first console commands via hdmi monitor, and after i see the xfe desktop but only if i put a keyboard on usb port. If there's no keyboard even with hdmi monitor attached i see nothing. And in the case there're hdmi monitor and keyboard usb attached, if i detach the usb keyboard the monitor show an error "there's no signal" like hdmi is turned off. Have you try this condition?
  Reply
#12
Hi,

I am still struggling in understanding what you  want to explain. Each new post I am getting more and more information from you but more confused than before


1. I have never tried a hdmi to vga adapter ... so I cannot give you any information if this type of adapter works the same as a standard direct hdmi to hdmi cable. The latter case is the only connection I used since 6 years with netPI only.

2. You say something about xfe desktop. How do you get it activated? Are you using netPIs original SD card and OS or are you using a different OS with you own SD card? Or are you using a Docker container example we made years ago here https://hub.docker.com/r/hilschernetpi/n...sktop-hdmi ?

3. Can you confirm that you see console outputs ALWAYS after you powered your netPI or not. I mean ALWAYS until netPI starts activating the desktop? Because console outputs is a MUST HAVE and tells me your netPI is working correctly on HDMI.

4. What happens if you are trying to connect your netPI via HDMI to a HDMI monitor? Is netPI then operating normal?

5. Just in case you are using the docker desktop example from here https://hub.docker.com/r/hilschernetpi/n...sktop-hdmi that we made public as a template to users I would say that I am not sure if I have ever started and used it without keyboard and mouse ... since this is in my eyes a setup a Desktop is made for. Since it is an open source code example located here https://github.com/HilscherAutomation/ne...sktop-hdmi, everybody is invited to copy it and make his own modifications to create his own Desktop and setup. What I also can definitively say is that during starting the desktop container via the https://github.com/HilscherAutomation/ne...rypoint.sh start script, this script maps all input devices from /dev/input into the container so that keyboard and mouse can get reachable in the container. 

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#13
(February-25th-2022, 04:52 PM).Armin@netPI Wrote: Hi,

I am still struggling in understanding what you  want to explain. Each new post I am getting more and more information from you but more confused than before


1. I have never tried a hdmi to vga adapter ... so I cannot give you any information if this type of adapter works the same as a standard direct hdmi to hdmi cable. The latter case is the only connection I used since 6 years with netPI only.

2. You say something about xfe desktop. How do you get it activated? Are you using netPIs original SD card and OS or are you using a different OS with you own SD card? Or are you using a Docker container example we made years ago here https://hub.docker.com/r/hilschernetpi/n...sktop-hdmi ?

3. Can you confirm that you see console outputs ALWAYS after you powered your netPI or not. I mean ALWAYS until netPI starts activating the desktop? Because console outputs is a MUST HAVE and tells me your netPI is working correctly on HDMI.

4. What happens if you are trying to connect your netPI via HDMI to a HDMI monitor? Is netPI then operating normal?

5. Just in case you are using the docker desktop example from here https://hub.docker.com/r/hilschernetpi/n...sktop-hdmi that we made public as a template to users I would say that I am not sure if I have ever started and used it without keyboard and mouse ... since this is in my eyes a setup a Desktop is made for. Since it is an open source code example located here https://github.com/HilscherAutomation/ne...sktop-hdmi, everybody is invited to copy it and make his own modifications to create his own Desktop and setup. What I also can definitively say is that during starting the desktop container via the https://github.com/HilscherAutomation/ne...rypoint.sh start script, this script maps all input devices from /dev/input into the container so that keyboard and mouse can get reachable in the container. 

Thx
Armin

Ok, here the is what i've done, i've installed the https://hub.docker.com/r/hilschernetpi/n...esktop-hdmi, connect a usb mouse, keyboard and a hdmi to vga adapter.
In these condiction all works well i can view the desktop of the netpi-desktop-hdmi image. The problem are some artifact (some strange lines appears on the monitor), and if i disconnect the mouse or keyboard the monitor show nothing.

I retry with a single hdmi - hdmi cable, and this works perfect, just like you said. Even without have attach mouse or keyboard i can see the monitor, and if i start with the mouse and keyboard attached and after i detach, the monitor still show without any problem.

Maybe the problem is the hdmi - vga adaptor that create some problem, but for my test i can use the hdmi-hdmi adapter.

Only one thing, is there a way to recognize a mouse or keyboard after the start of the netpi-desktop-hdmi image? If the mouse/keyboard are not present at start the sistem don't recognize it until you restart all the system.

Thanks
  Reply
#14
Hello, it is good to hear that the HDMI to HDMI combo is now working.

You are asking if a mouse and keyboard can be recognized after the Desktop container has been started ... no this is not possible and I explain you why. When a Docker Container is started then exactly at this time Docker makes a copy of all the recognized USB devices connected and makes them present in the container. It is a kind of freeze frame and even if you would connect mouse and keyboard aftewards the freeze frame in the containes isn't change any more. Of course in the Linux Host OS they are recognized ... but this information is not forwarded to the container. The readme file of the container tells you about this circumstance in one sentence.

It is the same like the graphics controller chip of the Raspberry Pi CPU recognizes a HDMI communication only at power on state once. If you would connect a HDMI cable after this recognition time, the HDMI port is remaining disable and is just black

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED]DHCP server not working m-yoshikawa 24 15,556 June-11th-2021, 07:04 AM
Last Post: tad
  Profinet stopped working (spidev spi0.0: SPI transfer timed out) Schranz 7 5,670 November-2nd-2020, 04:20 PM
Last Post: Armin@netPI
  Fieldbus Ports not working Schoko 13 9,697 June-29th-2020, 09:43 PM
Last Post: Armin@netPI
  netpi-desktop-hdmi with setting network=bridge tad 13 9,201 June-19th-2020, 12:50 PM
Last Post: tad
  Node-Red "http in"-Node not working DWxPro 8 8,495 June-19th-2020, 01:12 AM
Last Post: DWxPro
  Node Red stop working DSongra 1 3,221 February-12th-2020, 08:19 AM
Last Post: Armin@netPI
  [SOLVED] netPI stops working (502 - Bad Gateway) Andi 3 4,039 June-19th-2019, 03:58 PM
Last Post: Andi
  [SOLVED] Using netPI's HDMI port Rahulsagar 2 4,320 December-14th-2018, 02:29 PM
Last Post: Rahulsagar
  Auflösung in hilschernetpi/netpi-desktop-hdmi ändern dennis 5 4,770 November-15th-2018, 11:28 AM
Last Post: Armin@netPI
  usage of hilschernetpi/netpi-netx-ethernet-lan is working but costs 25% cpu power Michael_d 7 5,669 March-9th-2018, 10:52 AM
Last Post: Michael_d

Forum Jump:


Users browsing this thread: 1 Guest(s)