• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
usage as WLAN access point with hostapd
#1
Hey,

is it possible to run a hostapd in the container to use the netPi as WLAN access point or is the WLAN nic restricted to the host os?

Frank
  Reply
#2
Since we have other gateways running Linux without a Docker needing a Wifi connectivity too, we have pushed the Wifi configuration/setting into the Host Linux and provide the function as an additional Ethernet interface to the user ... in your case Docker and containers.

This means in the other hand that you have no chance to handle these settings in a container since they are all "assigned" to services running on the Host OS.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to access netPI? firefly 6 38 May-16th-2019, 02:31 AM
Last Post: firefly
  Wi-Fi access problem MGharat 3 11 March-12th-2019, 09:27 AM
Last Post: Armin@netPI
  access to netPI MGharat 2 19 March-7th-2019, 07:16 AM
Last Post: Armin@netPI
  [SOLVED] Access problems Azzamjj 8 170 January-25th-2019, 07:43 AM
Last Post: Armin@netPI
  Remote Access Jonas.Sellmann@outlook.de 12 455 September-20th-2018, 10:20 AM
Last Post: Armin@netPI
  [SOLVED] after WIFI enabled - no access paubau 7 261 August-30th-2018, 02:04 PM
Last Post: Armin@netPI
  Resart/Access NetPi from Remote Jonas.Sellmann@outlook.de 11 391 August-1st-2018, 11:06 AM
Last Post: Jonas.Sellmann@outlook.de
  Access Denied to LED1 / LED2 crthomas1234 1 104 July-12th-2018, 04:36 PM
Last Post: Armin@netPI
  DHCP/DNS issue: Couldn't access NetPI3 out-of-the-box zulliger@software-natives.ch 5 181 March-14th-2018, 06:47 PM
Last Post: adeeljsid
  Access netPI via Firefox Browser times out Armin@netPI 0 89 October-30th-2017, 08:37 PM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)