• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Control Panel not loading sometimes.
#1
Sometimes, the control panel interface display the following when loaded:

/*******************************************************************************
* Copyright © 2016 Hilscher Gesellschaft fuer Systemautomation mbH
* See Hilscher_Source_Code_License.txt
********************************************************************************/
sap.ui.controller("pages.EdgeServer",{onBeforeRendering:function(){this.getEdgeServerStatus()},getEdgeServerStatus:function(e){var t=sap.ui.getCore().byId("oRBEdgeServerEnable_id"),r=sap.ui.getCore().byId("oRBEdgeServerDisable_id"),o=sap.ui.getCore().byId("oEdgeServerTextViewID"),i=sap.ui.getCore().byId("runningEdgeServerButtonID");oServices_ob.getController().getServiceStatus("edgeserver",this.category,t,r,o,i,this,e)},setStatus:function(e){var t=oServices_ob.getController();void 0!==e&&!0===e?this.getEdgeServerStatus(t.updateItemIcon):t.updateItemIcon(void 0,this)},listItem:{},oLastSettings:void 0,runningButtonPressed:function(e){var t=oServices_ob.getController(),r=sap.ui.getCore().byId("oEdgeServerTextViewID");t.updateSericeStatus(e,"edgeserver",this.category,r,this)},updateState:function(e){var t=sap.ui.getCore().byId("oRBEdgeServerEnable_id"),r=sap.ui.getCore().byId("oRBEdgeServerDisable_id");oServices_ob.getController().updateAutostartState(e,"edgeserver",this.category,t,r,this)},category:"Edge Server"});
  Reply
#2
It looks like this error is due to a login time out. I mean, when this page is let opened into the browser for a while, and you hit refresh, then the text is displayed as such.
When I just close the window and reload the page via the Control Panel main dashboard, I get the login/password again, and then it works.

Anyway, I just noticed something also, into the "Package Manager", with the original firmware, you ave the list of installed packages displayed.
Here with the V1.1.0.0, the list is empty , hitting the refresh button doesn't change anything.

I was wondering something, could it be that when I upgraded the NetPi I had removed too early the stick or it didn't copied everything on the flash?
I mean, I have no log or information that I can check if the new firmware was installed correctly.

Perhaps an improvement would be to have a check into the Info Center and display that the firmware is installed correctly (kind of integrity check?).

btw , I did the upgrade without HDMI screen, so I didn't see anything while the update was done.
  Reply
#3
181 Wrote:Here with the V1.1.0.0, the list is empty , hitting the refresh button doesn't change anything.
Yes the behaviour showing an empty list is correct with 1.1.0.0. With the previous version 0.9.1.0 we were showing every installed package ... but there was no real benefit for the customers to know that.

Now with 1.1.0.0 only those packages are shown that have been updated/changed to a specific version just in case. With this method you can easily see what is different compared to the main version you updated to by USB stick.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#4
181 Wrote:Perhaps an improvement would be to have a check into the Info Center and display that the firmware is installed correctly (kind of integrity check?).

Not needed. netPI would never boot if the checksum of the firmware wouln't match.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#5
181 Wrote:It looks like this error is due to a login time out.

Yes this is explicitly requested due to a demand of IEC 62443. Browser have to time out after a while, to give nobody a change or reduced change to take over your open session.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  CODESYS - Control for Raspberry Florian 1 29 March-18th-2019, 06:16 PM
Last Post: Armin@netPI
  [INFO] RESTful API for Docker remote control Armin@netPI 0 98 December-17th-2018, 10:15 AM
Last Post: Armin@netPI
  [SOLVED] External Portainer Control Flo_Lo 1 117 October-18th-2018, 01:49 PM
Last Post: Armin@netPI
  Loading times for images from Docker Hub Armin@netPI 0 103 December-3rd-2017, 01:47 PM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)