• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Auflösung in hilschernetpi/netpi-desktop-hdmi ändern
#1
Sali zame,

wir möchten gerne ein im node-red programmiertes Dashboard in net-desktop-hdmi Container anzeigen. Das ganze läuft bereits und auch stabil.

Da das Dashboard recht klein ist möchten wir gerne die Auflösung auf 800x600 fest einstellen. Ich habe es aber nicht hinbekommen die Auflösung zu reduzieren. In den Einstellungen unter Display ist ausschließlich 1920x9xx anwählbar.

Übersehe ich etwas?

Gruss Dennis
  Reply
#2
Well Dennis,

during the development of the netPI project we had indeed discussions about how to deal with all the original Raspberry Pi 3 options you usually configure in the /boot/config.txt file on an "open" SD card as described here.

This file can be compared to the BIOS you usually find installed on your PC. As you maybe know the Raspberry CPU is booted through its Graphics CPU and not through the main CPU. And this GPU is fed with a file named bootcode.bin that has to be located on the first partition of the SD card to be found during the boot sequence. Once the bootcode has been started it locates the config.txt file and starts to interpret the settings and make all adjustments accordingly.

In the list of the different options you find also those setting the screen resolution driven on the HDMI port. And now comes the problem ... on netPI you have no access to the config.txt file cause on netPI the SD card is not freely accessible due to security reasons. Bound to this fact we decided to configure the screen resolution in the config.txt file on netPI to auto detection mode which adjusts the screen resolution to the connected monitors maximum resolution possible. In your case it seems to be 1920X1080.

I have not found any possibility on the web to adjust the raspberries screen resolution to a specific value after it has booted. So I am sorry to say at the moment netPI drives the max resolution possible with your monitor and you have no possibility to change it, neither in config.txt nor in hdmi-container.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Sali Armin,

danke für deine Rückantwort. Derzeit hängt in der Tat ein FullHD Screen am HDMI Port. Er findet  komischerweise derzeit als maximale Auflösung 1824x984. Ich habe es mit einem zweiten Monitor gegengeprüft. Wie kommt diese Auflösung zu stande?

Grundsätzlich ist es für uns kein Problem wenn er immer die native Auflösung findet.

Gruss Dennis
  Reply
#4
Well Dennis,

I found this post on the web: https://www.foxplex.com/sites/raspbian-a...0-aendern/ about this special resolution.

It seems indeed to be always monitor related which resolution the netPI device finds finally as maximum resolution.

I have tested the HDMI container again just a minute ago with a new DELL Monitor and I am getting 1920x1080 as default resolution with it. Look:

   
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#5
Sali Armin,

kann es daran liegen das ich ein NET-IOT Edge "Connect" verwende? Ist der Container auf einen NET-IOT Edge verwendbar?

Ich habe mit zig Monitore gegengeprüft. Es ist immer die Auflösung 1824x984. Ich gehe mittlerweile davon aus das es nicht am Monitor liegt.


Hardware             ID00000000bec78c15
Model name         NIOT-E-TPI51-EN-RE
Firmware version  V1.1.2.0

Gruss Dennis
  Reply
#6
Dear Dennis,

even if the device "NIOT-E-TPI51-EN-RE" is not supported through this forum since it is not a netPI unit and supported by hotline@hilscher.com instead, I took a chance to load the HDMI container onto my personal NIOT-E-TPI51-EN-RE. And I am using the same software version as you V1.1.2.0.

But I am sorry to say. On my DELL monitor I am getting the same result as on my NIOT-E-NPI3-EN I used the days before. My monitor tells me still 1920x1080 with 60Hz also with the TPI51 model.

But Dennis, let me ask you this. What type of cable are you using? If you are using a DVI to HDMI adapter in between I am pretty sure it does not work. I am using a HDMI to HDMI V1.4 cable in between device and monitor.

Regards
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] netPI with Raspbian Desktop firefly 7 49 May-17th-2019, 09:15 AM
Last Post: Armin@netPI
  [SOLVED] Using netPI's HDMI port Rahulsagar 2 76 December-14th-2018, 02:29 PM
Last Post: Rahulsagar
  [SOLVED] hilschernetpi/netpi-nodered-fieldbus Fieldbus configurator can't be open Andreas 6 200 June-11th-2018, 09:12 AM
Last Post: Armin@netPI
  usage of hilschernetpi/netpi-netx-ethernet-lan is working but costs 25% cpu power Michael_d 7 158 March-9th-2018, 10:52 AM
Last Post: Michael_d
  Profinet Example in hilschernetpi/netpi-netx-programming-examples Thomas 2 132 November-18th-2017, 08:44 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)