• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
activate Ethernet cifx0
#1
On page 44 of the German user manual for the NetPi it says: "In the delivery state, the Ethernet interface cifx0 is deactivated. Section "Activate Ethernet interface cifx0" (see below) describes how to activate this interface. "However, how cifx0 is activated is no longer described below. How can I now activate the interface so that I can configure IP routing according to page 52?

Addition: I have newly installed version 1.2.2.0.
  Reply
#2
Well this chapter is indeed misleading and needs a rework in the next document revision.

To activate cifx0 ok netPI RTE 3 the container https://hub.docker.com/r/hilschernetpi/n...ernet-lan/ needs to be deployed

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Hello Armin,
many thanks for the answer.
The container deployment description does not match the real interface in portainer.io. For example, you should enter the IP address and subnet mask under Runtime -> Env. But this field does not exist. In the end I was able to install the container but the cifx0 interface is still not displayed in the control panel. I would like to use Netpi to route between two subnets.
Thx
Christian
  Reply
#4
Hi Christian,

from time to time we are updating the netPI system software and also portainer.io cause of security reasons. Sometimes new portainer versions are not 100% compatible to previous versions as we have documented them ... namings were changed and it is not always easy to recognize and follow them.

Here is where you find the "Env = Environment variables" nowadways:
   

Anyway you are right, the description should fit 100% and so I will update the container description accordingly.

Three things are important anyway to run cifx0:
  • First of all do not use the environment variables to set the ip address etc.. Your aim is it to set it up via netPIs control panel
  • Second is use the host mode as described. Only the host mode will bring the cifx0 available to you in netPIs control panel
  • Update the netPI system software to the latest version V1.2.2.0. All versions lower than V1.2.2.0 are not showing the cifx0 interface in the netPI control panel. Here you find the system software https://www.netiot.com/netpi/industrial-raspberry-pi-3/ in the download section. In the FAQ section you find how to update netPI Using an USB stick. Use a "fast" USB stick that boots fast else it is not recognized by Raspberry CPU during power on times.
Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  cifx0 and Node-Red fabio1975 5 236 November-22nd-2021, 01:13 PM
Last Post: Armin@netPI
  linux bridge eth0 and cifx0 carmel85 3 1,476 August-13th-2020, 08:41 AM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 2,190 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  normal ethernet port using for Profinet MGharat 4 1,832 August-7th-2019, 10:39 AM
Last Post: hannes
  RTE3 Use real time ethernet as "normal" ethernet interface hannes 50 9,509 May-9th-2019, 04:28 PM
Last Post: Armin@netPI
  niot-e-npi3-51-en (RS485 <-> Industrial Ethernet) merklethomas 6 1,937 April-26th-2019, 01:38 PM
Last Post: Armin@netPI
  Modbus TCP Connection via RTE Ethernet Ports Flo_Lo 18 5,141 April-15th-2019, 09:50 PM
Last Post: Armin@netPI
  USB/Ethernet adapter slos 4 1,620 April-8th-2019, 09:11 AM
Last Post: slos
  IP Realtime Ethernet michu252 7 2,359 August-21st-2018, 10:41 AM
Last Post: Armin@netPI
  Activate Projects Feature in NodeRed AlexFdez 2 1,448 May-7th-2018, 10:58 PM
Last Post: AlexFdez

Forum Jump:


Users browsing this thread: 3 Guest(s)