• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Touchscreen with DVI Port
#1
Hello,

I'm trying to use the hdmi-container (https://hub.docker.com/r/hilschernetpi/n...sktop-hdmi) together with an touchscreen. The touchscreen unfortunately has only a DVI or VGA port. The touchscreen was plugged in during the container deployment, but there isn't any signal on the screen.

On multiple Raspberry Pi forums and tutorials I've seen some workarounds using the config.txt to add certain settings. Can this be done on a netPi? How else is it possible to use a display without a HDMI port (on a different screen with HDMI this was no issue)?

Thanks in advance
Dipro
  Reply
#2
Well this is easy explained. HDMI is a bidirectional bus and based on netPI's config.txt settings the graphic processor is auto detecting HDMI signals and maximum resolution. But if there are no HDMI signal deteced during auto-detection phase then the graphical unit keeps the screen black.

Cause of the security setting of netPI changing the config.txt file over the netPI embedded Linux is not possible. The only chance I see is to open the netPI housing, take the SD card out and make changes of config.txt file manually and inserting the SD carc back. But the next update just in case there is one coming, will definitively overwrite you config.txt setting.

Of course you can use the free Raspbian OS at any time and use your own SD card. netPI is 100% compatible to Raspberry PI3B. So what is running on the original device will run on netPI the same.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Docker exposed port don't send data on eth0 COswald 3 99 July-15th-2021, 02:10 PM
Last Post: Armin@netPI
  Accessing a modbus device connected to RTE port from Node-RED tad 10 2,450 October-2nd-2020, 07:21 AM
Last Post: Armin@netPI
  Receive at startup additional data through the Fieldbus Port Schranz 1 851 September-10th-2020, 10:55 AM
Last Post: Armin@netPI
  normal ethernet port using for Profinet MGharat 4 1,287 August-7th-2019, 10:39 AM
Last Post: hannes
  [SOLVED] Using netPI's HDMI port Rahulsagar 2 1,222 December-14th-2018, 02:29 PM
Last Post: Rahulsagar

Forum Jump:


Users browsing this thread: 1 Guest(s)