• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
operating Console of a container on netPI connected to Wi-Fi tethering
Dear Armin,

I'm in trouble now.
A netPI isn't connected to a company LAN so that netPI and my PC are now connected by Smartphone's tethering function.

netPI  _____   Smartphone  _____ Internet

With this environment, I was able to pull and deploy a container from Docker Hub.
Next, I want to update software packages by commanding 'apt update' on Console.

But, as attached files, it seems not to connect Internet site.
- 'apt update' couldn't find Internet sites.
- Ping didn't get response from Yahoo.

I think it is not a netPI's problem, it may be caused by something tethering functionality.
But, if you know something to solve this problem, I would appreciate it.

Best regards,

Attached Files Thumbnail(s)
This is my explanation: your DNS name server configuration of your Wifi setup seems not to be correct. I see in one of your screen shots the DNS server setup is 192.168.43.xxx which maybe is the ip address of your smartphone, right? But usually a smartphone does not have a DNS server integrated, so all tries to resolve internet names like yahoo.co.jp across the non existent smartphone DNS server lead to a dead connection.

In my opinion you have to change the DNS server setting to a public DNS server as explained here https://developers.google.com/speed/public-dns while the gateway remains of course the IP address of your smartphone in your setup.

This is all you need to do
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

I tried it myself today and had the same effect but I found the reason: in the whole netPI network setup it is allowed to have only one network gateway configured.

In your screen shot of your wifi connection I see a gateway address configured which is good. But I am pretty sure your netPI has a second gateway address in LAN eth0 setup also configured.

What you have to do is to remove the gateway address in LAN eth0 setup. This gateway address has always higher priority compared to Wifi the gateway address.

So configure LAN eth0 setting to static IP address and the you can remove the gateway address like my screen shot with the backspace keyboard key.


And in my test setup a DNS server in Wifi configuration was not necessary at all by the way. So forget my previous post.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Dear Armin,

Thank you very much for your investigation and information.
I was able to execute 'apt update' on the console after the setting.

Even though it was not a netPI specific issue, I appreciate your kind support.
Best regards,

Possibly Related Threads…
Thread Author Replies Views Last Post
  TOSILOCK for CONTAINER COswald 3 416 July-13th-2021, 11:32 AM
Last Post: Armin@netPI
  Access to RTC from my own container application tad 1 742 March-19th-2021, 02:58 PM
Last Post: Armin@netPI
  [SOLVED] Starting services/commands/scripts at startup of a container Jonas.Sellmann@outlook.de 9 2,234 March-9th-2021, 08:47 AM
Last Post: WalterSchaefer
  OpenVPN container Armin@netPI 0 583 January-3rd-2021, 12:13 PM
Last Post: Armin@netPI
  NIOT-E-NPIX-4DI4DO with netpi-netx container WalterSchaefer 3 1,199 November-25th-2020, 01:06 PM
Last Post: zen89
  NPIX-4DI4DO and NetPi-Nodered container issues alhammi 4 1,599 November-16th-2020, 01:35 PM
Last Post: alhammi
  Get host MAC via REST API inside container bschandra 4 1,589 November-16th-2020, 09:26 AM
Last Post: bschandra
  Accessing a modbus device connected to RTE port from Node-RED tad 10 3,412 October-2nd-2020, 07:21 AM
Last Post: Armin@netPI
  Exporting and importing container images Armin@netPI 3 1,339 May-20th-2020, 11:24 AM
Last Post: COswald
Exclamation Creating a container Linnerz 6 2,091 March-6th-2020, 02:47 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)