• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Internet on the fieldbus-side
Good Morning Hattersheim,

my problem is, that I have a Industriel PC behind the NIOT-E-TPI51-EN-RE and this is not able to access the Internet.
This would be great for normal situation, but we have to be able to do so.

What is special here? We don't use the fieldbus side in ProfiNet-Mode, but in LAN-Mode via the LAN-Enabler Docker-Container.
I have also installed the TOSIBOX-Soft-Lock, which is working fine. Without any special routes in the Gateway.
Is where something special with this?

Here are some screenshots of the LAN and route settings in the gateway:



I'm looking forward reply.

Kind regards,

Carsten Oswald

my explanation why the TOSIBOX container application works without any routing setup because it is always the initiator of the local TCP/IP traffic sent to the cifx0 interface and its connected devices behind. This is just a standard communication between two local IP addresses where no routing information is needed but just the two IP addresses and no gateway firewall is blocking the access.

In your new use case now the initiator whereas is the PC sitting behind the cifX0. On this PC you need to configure a gateway first of all next to its IP address 192.168.1.x. This gateway needs to be set to the IP address of the cifx0 interface which So all traffic of the PC outside the local network 192.168.1.x will be sent to this gateway address respectively cifx0 instead. As next you should also configure a DNS server on the PC. Usually a DNS server address works fine. Else a simple "ping google.de" will not work on your PC since there is no name resolution configured.

Finally instead of configuring a cifx0 routing path as you did you have to configure the eth0 firewall on your Connect gateway accordingly:


That is all you need to do. This is not a routing problem since the default route is internally configured to eth0 anyway but a firewall problem. You have to trust the eth0 interface as NAT-trusted.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hello Armin,

many thanks for your quick reply.
Yes, it was the NAT.
After enabling NAT support everything is good.
The TOSIBOX is also running.

Greetz from Haan,


Possibly Related Threads…
Thread Author Replies Views Last Post
  Receive at startup additional data through the Fieldbus Port Schranz 1 305 September-10th-2020, 10:55 AM
Last Post: Armin@netPI
  Fieldbus Ports not working Schoko 13 1,202 June-29th-2020, 09:43 PM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 749 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 808 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 674 August-20th-2019, 07:22 AM
Last Post: Armin@netPI
  [SOLVED] WebConfig netpi-nodered-fieldbus JohnyD94 13 1,092 May-6th-2019, 12:20 AM
Last Post: JohnyD94
  [SOLVED] hilschernetpi/netpi-nodered-fieldbus Fieldbus configurator can't be open Andreas 6 889 June-11th-2018, 09:12 AM
Last Post: Armin@netPI
  fieldbus in error Schranz 7 803 March-13th-2018, 07:28 AM
Last Post: Armin@netPI
  Using SSH in netPI-nodered-fieldbus image Schranz 3 601 March-6th-2018, 06:29 PM
Last Post: Armin@netPI
  Usage of Fieldbus in and out and FRAM read and write nodes Schranz 8 931 March-5th-2018, 05:42 PM
Last Post: Schranz

Forum Jump:

Users browsing this thread: 1 Guest(s)