• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED]DHCP server not working
#21
I'm having the same situation. Btw. there is a good documentation on sysrq: https://matoski.com/article/emergency-re...nux-sysrq/

In addition I'm having the issue the netPI is getting very hot and the control panel is no more accessible and telling me there is some issue with the system time.


Attached Files Thumbnail(s)
   
  Reply
#22
Dear all experts,

With latest firmware(v1.2.2.0), this problem does not occur.

Thank you for resolving this problem.

Sincerly,
  Reply
#23
Dear Armin,

This thread contains very good information.
I tried to execute the followings.

echo 1 >/proc/sys/kernel/sysrq && echo s > /proc/sysrq-trigger && sleep 3 && echo o > /proc/sysrq-trigger

- I changed 10 to 3 in the 3rd command.
- I changed b to o in the 4th command. It means reBoot to shutdOwn.

The reason for the above is as follows.

- I think 3 seconds are enough to synchronize between memory and microSD card.
- Before turning netPI off, I think 'shutdown' should be selected instead of 'reboot'.


I would like to know your opinion, please.
Thank you very much for your advice.
Best regards,
  Reply
#24
Hello Tad,

sleep 3 is much time. I would reduce it to sleep 1 since this is plenty of time for writing data to the card which is usually a thing of some micro seconds.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#25
Dear Armin,

Thank you very much for your quick response.
I want to shut down netPI according to the contents of this thread with the sleep 1.

Best regards,
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  OPC UA server with NetPi RTE DSongra 9 144 July-27th-2021, 12:01 PM
Last Post: Armin@netPI
  REST API server data communication MGharat 2 113 July-21st-2021, 07:01 AM
Last Post: MGharat
  Profinet stopped working (spidev spi0.0: SPI transfer timed out) Schranz 7 1,450 November-2nd-2020, 04:20 PM
Last Post: Armin@netPI
  Fieldbus Ports not working Schoko 13 2,691 June-29th-2020, 09:43 PM
Last Post: Armin@netPI
  Node-Red "http in"-Node not working DWxPro 8 2,046 June-19th-2020, 01:12 AM
Last Post: DWxPro
  how to pick up PROFINET data and store them to OPC UA server on Node-RED/netPI. tad 7 2,052 March-16th-2020, 10:21 AM
Last Post: Armin@netPI
  Node Red stop working DSongra 1 1,114 February-12th-2020, 08:19 AM
Last Post: Armin@netPI
  PM - develope OPC UA Server using the Codesys Lingyue 5 1,342 January-17th-2020, 11:12 AM
Last Post: Armin@netPI
  [SOLVED] netPI stops working (502 - Bad Gateway) Andi 3 1,130 June-19th-2019, 03:58 PM
Last Post: Andi
  New Container example "OPC UA server" Armin@netPI 0 965 April-12th-2019, 11:51 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)