• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
docker.service start failed
The same problem for me today. This is bad.
How can i restore the file content without reflash firmware?

Problem Solved!
I attach the internal sd to a computer and after editing the files and reboot all works well.

For me the ssh service is essential for this type of problems. Is there a way to enable it from the web-gui?
Hi there,

good to hear that you find a way yourself to solve problem and to recover the deleted docker conf.file. This is a good idea by the way.

I am sorry to say that SSH was not an option from the beginning when netPI product was defined 5 years ago. Even if you would have access to the Linux host over SSH you can't do anything with it since it is a secured Linux and just installs signed HIlscher packages only and never any packages from the web.

These are the one and only options:

  1. You can of course deploy a container that includes SSH ... but then this SSH will get access to the internals of the container ... never to the host Linux. For example this one: https://hub.docker.com/r/hilschernetpi/netpi-raspbian
  2. Also you can open the netPI device housing by unscrewing the screws, remove the included Hilscher OS SD card and put it aside and use then the netPI with an own SD card and Raspbian OS. Then you have all possibilities and you own choice.

The docker service start problem was solved in the system software version V1.2.2.0 by the way. So even if you have corrected the problem yourself, I strongly recommend to update to version V1.2.2.0

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hello everyone,

We have also Docker problems, with some containers on very new states of the new bought netPI's. Docker Hub Exports have "architecture": "amd64" in their JSON config and "io.balena.architecture": "armv7hf" - maybe that should be aarch64 or arm64? ( V1.2.2.0 )

The from the netPI exported image is seen as an amd64 architecture from other tests on RPI3 and wont work well.

see 78f6ab1d8d9a237a63aa4f12452bdbce0250730523c3ec616d803382ac019aef.json - inside the netPI Node-RED's image.tar

I have the problem again, a fresh installed Hilscher netPI even with original card dies after a few days of running the Docker service and Docker does not start anymore. A reset via USB-Stick helps, but some crashes the Docker Service over time again with a lot of cgroup errors in the syslog as I sent to Armin.

Problem of amd64 is on - directly export from netPI (v1.2.2 Barcode end number 2 very new devices and images from docker as well)
  • hilschernetpi/netpi-codesys-basis
  • [b]hilschernetpi/netpi-nodered[/b]
  • [b][b]hilschernetpi/netpi-netx-ethernet-lan[/b][/b]
  • [b][b]hilschernetpi/netpi-[/b]raspian[/b]

The OpenVPN is OK and shows arm architecture.
  • hilschernetpi/netpi-openvpn

Attached Files Thumbnail(s)
Hello Biancode,

the Docker start problem corrected in version relates back to an empty daemon.json. It is caused by a Linux file system synch problem not writing the file physically to the SD card and leaving the touched file empty.

During the next start of the device the Docker Daemon fails to start since the file is empty. Devices in thie state indicate the following error in the log file:

unable to configure the Docker daemon with file /etc/docker/daemon.json: EOF

In the log files you sent to me via private messages in none of these I was able to see the error above. So your problem does not relate to the problems all the others have in this thread. In you log file whereas I see a lot of other things not starting and the root cause it not known right now and needs in-deep examination.

It would be nice to open a new thread with a new syslog file that shows your problem if it occurs again. I would be also nice to get a list of all the containers you are using while the error occurs.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads…
Thread Author Replies Views Last Post
  Docker amd64 instead of arm biancode 3 59 January-17th-2021, 09:40 PM
Last Post: Armin@netPI
  Docker cannot find image COswald 16 1,092 May-18th-2020, 07:15 AM
Last Post: COswald
  After „Rebuild“ of Docker neither the node-RED nor the dashboard can be accessed MAK 4 797 January-31st-2020, 02:14 PM
Last Post: MAK
  Cannot start container Magnus 7 953 October-16th-2019, 01:00 PM
Last Post: Armin@netPI
  [SOLVED] Docker GUI login issue MGharat 1 468 September-19th-2019, 11:50 AM
Last Post: Armin@netPI
Information netPI Docker REST API patrick 1 594 July-16th-2019, 02:45 PM
Last Post: patrick
  [SOLVED] Pull Docker Image a.w.d.m. 8 710 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  [SOLVED] Docker issues AlexRegev 7 870 June-26th-2019, 02:14 PM
Last Post: AlexRegev
  docker timing MGharat 2 448 June-13th-2019, 08:57 AM
Last Post: patrick
  Launching multi-containers at a time - Docker stacks Armin@netPI 0 400 June-4th-2019, 04:11 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)