• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
docker.service start failed
The same problem for me today. This is bad.
How can i restore the file content without reflash firmware?

Problem Solved!
I attach the internal sd to a computer and after editing the files and reboot all works well.

For me the ssh service is essential for this type of problems. Is there a way to enable it from the web-gui?
Hi there,

good to hear that you find a way yourself to solve problem and to recover the deleted docker conf.file. This is a good idea by the way.

I am sorry to say that SSH was not an option from the beginning when netPI product was defined 5 years ago. Even if you would have access to the Linux host over SSH you can't do anything with it since it is a secured Linux and just installs signed HIlscher packages only and never any packages from the web.

These are the one and only options:

  1. You can of course deploy a container that includes SSH ... but then this SSH will get access to the internals of the container ... never to the host Linux. For example this one: https://hub.docker.com/r/hilschernetpi/netpi-raspbian
  2. Also you can open the netPI device housing by unscrewing the screws, remove the included Hilscher OS SD card and put it aside and use then the netPI with an own SD card and Raspbian OS. Then you have all possibilities and you own choice.

The docker service start problem was solved in the system software version V1.2.2.0 by the way. So even if you have corrected the problem yourself, I strongly recommend to update to version V1.2.2.0

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads…
Thread Author Replies Views Last Post
  Docker cannot find image COswald 16 1,000 May-18th-2020, 07:15 AM
Last Post: COswald
  After „Rebuild“ of Docker neither the node-RED nor the dashboard can be accessed MAK 4 719 January-31st-2020, 02:14 PM
Last Post: MAK
  Cannot start container Magnus 7 907 October-16th-2019, 01:00 PM
Last Post: Armin@netPI
  [SOLVED] Docker GUI login issue MGharat 1 409 September-19th-2019, 11:50 AM
Last Post: Armin@netPI
Information netPI Docker REST API patrick 1 528 July-16th-2019, 02:45 PM
Last Post: patrick
  [SOLVED] Pull Docker Image a.w.d.m. 8 627 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  [SOLVED] Docker issues AlexRegev 7 786 June-26th-2019, 02:14 PM
Last Post: AlexRegev
  docker timing MGharat 2 379 June-13th-2019, 08:57 AM
Last Post: patrick
  Launching multi-containers at a time - Docker stacks Armin@netPI 0 388 June-4th-2019, 04:11 PM
Last Post: Armin@netPI
  [SOLVED] Diagnostic service MGharat 1 302 April-2nd-2019, 09:45 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)