• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] WebConfig netpi-nodered-fieldbus
Thanks allot for the very detailed information!

I'm glad i had the same intentions as a expert. My plan was also to get a new container, add port 22 (or what ever..), install ssh and get via ssh on the device, because the webconsole and I will never be friends.

But... i had to research all the right configurations for the SSH (i guess i would have copied the config from other hilscher images with ssh). But with all of your information i don't need to do so.

I just try a few times and look if it will work. I'm finishing my diploma within the next 3 days, all the other stuff is working, i had some other problems which had thrown me back for weeks, that's why i'm this late with working on my IoT connection. If it's work now, it's fine, but if not, i better spend time to explain why than try to fix something without knowing if it will work. But after the diploma, i will bring it to work for sure. All i want to say: don't treat it as ultra urgent for me. My goal for the diploma was a solution or knowing WHY it's not working and have a confirmation, that this problem is not caused by wrong config by myself. So for the next 3 days, i've got everything i need.

Thanks for your amazing respond time and very high-quality informations!
I got it woking under v0.20.5 right now. The problem is that Node-RED V0.20.5 wants to have custom nodes in a different folder than we put it since the beginning of the fieldbus node development.

Could be that this path needs to be added into the v0.20.5 settings.js file now, but this is too much investigation for me to look for the righ answer.

Tomorrow I will change the source code and I will copy it into the right path where V0.20.5 wants to have it by default and then the problem is gone.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

New container with Node-RED V0.20.5 is online
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Thanks allot. I pulled the image after you changed the dockerfile to the old version of nodeRED. And everything worked as it should!

Possibly Related Threads…
Thread Author Replies Views Last Post
  NPIX-4DI4DO and NetPi-Nodered container issues alhammi 4 399 November-16th-2020, 01:35 PM
Last Post: alhammi
  Internet on the fieldbus-side COswald 2 210 October-19th-2020, 01:40 PM
Last Post: COswald
  NodeRed and EtherCAT Schranz 3 759 September-23rd-2020, 08:01 AM
Last Post: Armin@netPI
  Receive at startup additional data through the Fieldbus Port Schranz 1 296 September-10th-2020, 10:55 AM
Last Post: Armin@netPI
  Fieldbus Ports not working Schoko 13 1,178 June-29th-2020, 09:43 PM
Last Post: Armin@netPI
  [SOLVED] netPI with Raspbian Desktop firefly 8 789 November-28th-2019, 06:01 PM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 733 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 797 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 661 August-20th-2019, 07:22 AM
Last Post: Armin@netPI
  [SOLVED] netPI stops working (502 - Bad Gateway) Andi 3 499 June-19th-2019, 03:58 PM
Last Post: Andi

Forum Jump:

Users browsing this thread: 2 Guest(s)