• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] nodered : flows_localhost deleted after creating an image from container

i recently get an issue after creating a safe image from my nodered container.
First, when creating the image, an error appears but later the image was created as expected.
Then, when i want to deploy something in nodered, another error pop up, saying a file is missing..
I looked into the folder and cant even create a new file from the backup file.

I dont know when this started, but at the beginning everything worked good..
Thats not a really big problem because i safed the flows to clipboard, but i wonder if somebody can tell me the reason.

Best regards,


Attached Files Thumbnail(s)
Dear Paul,

have you maybe disconnected netPI from power unintended or have you had a power outage or power loss without shutting down netPI via the Web GUI?

What I can definitively say is that Linux caches write accesses to the file system. Imagine you were updating Node-RED by deploying a new flow. This file is definitively cashed ... for some seconds. If then you have a power drop this file could get lost.

Whenever netPI's Linux starts is checks the file system. Broken files will be copied into an internal "lost + found" folder (you can't access to this folder), but they are no more at their original place. This could be a reason why there is no file any more.

Right now I have no explanation why you can't create a file in the container any more.

But how do you get this things working again now? Repowering netPI? Loading the container again?

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

No there was no power drop as far as i can tell.
It doesnt happened the first time, i think i can reproduce the problem by creating again a new image from my container.

The flow file is lost then but after restarting netPI, i can import my safed data and everything works fine again..

Thanks for reply,

Thank you Paul.

I am glad to hear that you can recover your system.

But still I am very curious guy and I want to understand the root cause of the problem and maybe I can get your problem reconstructed.

So basically when you clone a running container, by tagging it, my expectation is that Docker Deamon makes a 1:1 copy. And afterwards when you start your copy everything should work as before.

But let me ask you this: have you stopped the Node-RED container before cloning it? Maybe that is the problem. A container you make a copy from should never run, cause there are threads running that maybe use cached data in RAM. So in this case a flow file could easily not being placed on the SD card (deleting the file first was executed, but not writing) and then a copy of course will also not include this file.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

So there we got the problem  Rolleyes   i dont think that i stopped the container before creating the image.
Next time i'll do it the right way.     


**another thing, i have problems with mapping an usb device to my container..
plugged in the usb stick, restarted netPI and then tried to add the device via /dev/ttyUSB0 , /dev/ttyUSB1 , /dev/USB2
but nothing worked.. any hints?
i read the other thread, installed the firmware but error "no such file or directory" appears.
Yes sure I have.

Read this topic here https://forum.hilscher.com/Thread-SOLVED...-Container

Not every USB device maps to /dev/ttyUSBx automatically. Linux divides them into different classes and then maps those to different /devs. You need to know indeed which one to map it right.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Yes, i read this thread before but it didnt helped..
In my case (SanDisk16gb) i found out that i have to use /dev/sda1 :-)
have a nice day


Possibly Related Threads…
Thread Author Replies Views Last Post
  NodeRed and EtherCAT Schranz 3 219 September-23rd-2020, 08:01 AM
Last Post: Armin@netPI
  Exporting and importing container images Armin@netPI 3 162 May-20th-2020, 11:24 AM
Last Post: COswald
  Docker cannot find image COswald 16 311 May-18th-2020, 07:15 AM
Last Post: COswald
  PHP-Apache Image hsammer 3 103 March-12th-2020, 05:23 PM
Last Post: hsammer
Exclamation Creating a container Linnerz 6 236 March-6th-2020, 02:47 PM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 264 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  Cannot start container Magnus 7 221 October-16th-2019, 01:00 PM
Last Post: Armin@netPI
  Generate VLAN interfaces in container FrankJacob 7 195 September-26th-2019, 03:19 PM
Last Post: Armin@netPI
  create container in Portainer v1.12.4 dcatteeu 2 141 September-9th-2019, 12:12 PM
Last Post: dcatteeu
  UMTS/LTE support via USB router/modem sticks in a container Armin@netPI 3 258 September-5th-2019, 02:07 PM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)