Hilscher Forum
Problems with NTP setup - Printable Version

+- Hilscher Forum (https://forum.hilscher.com)
+-- Forum: netPI - Ruggedized Raspberry Pi with Industrial Ethernet (https://forum.hilscher.com/Forum-netPI-Ruggedized-Raspberry-Pi-with-Industrial-Ethernet)
+--- Forum: Software (https://forum.hilscher.com/Forum-Software)
+--- Thread: Problems with NTP setup (/Thread-Problems-with-NTP-setup)

Answer - adeeljsid - March-14th-2018

I am using netPI for educational and research purposes. I have connected 5 netPI devices to a LAN (administered by pfsense) and I have configured a static IP for each. I can access them from other devices (like laptops) inside the LAN. When I try to set the NTP server for time synchronization, status becomes idle from n/a and nothing happens afterwards. II have checked several time that the Internet connectivity is available by checking Internet status on other devices in the LAN. Because of this problem, I cannot even pull the images and run it as containers. Can you please guide me what is the problem? Is it the problem with Static IPs but I don't think if its the case.

Time server: de.pool.ntp.org and tried others as well!

Answer - Armin@netPI - March-15th-2018

This need to be verified. I personally use my netPI with DHCP environment only.

Have you tried to use instead of de.pool.ntp.org the resolving IP address

Can you try this. Cause if you configured static IP and not the DNS server, then the NTP requests to de.pool.ntp.org cannot be resolved. So just try the ip address and give a feedback.

Answer - adeeljsid - March-16th-2018

I tried to use this IP address but it didn't work. BTW I have also entered the DNS server IPs in the LAN settings.
Now I have enabled the DHCP server on pfsense router as well. but still it doesn't work. The status becomes 'idle' after 'connecting to' appears.

Answer - adeeljsid - March-16th-2018

I have solved the problem the other way. I set up a local NTP server in my pfsense and synchronized all the devices to the local pfsense NTP server and it works. I still don't know why the netPIs were not able to synchronize with external NTP servers although I tried a lot of settings. Please update me if you solve this issue!

Answer - Armin@netPI - March-17th-2018

I will give that issue a priority to look at.

I need to setup a small local network in the office, otherwise I have to urge our test team to look at it. But usually I want to see an open issues myself.

I will keep you informed.