Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums



(Advanced Search)

Forum Statistics
» Members: 394
» Latest member: dean.leek@dematic.com
» Forum threads: 370
» Forum posts: 1,863

Full Statistics

Latest Threads
connecting a microphone v...
Forum: Software
Last Post: Armin@netPI
July-9th-2020, 07:02 AM
» Replies: 15
» Views: 48
PROFINET to OPC UA data c...
Forum: Projects
Last Post: Armin@netPI
July-7th-2020, 12:20 PM
» Replies: 0
» Views: 6
Fieldbus Ports not workin...
Forum: Software
Last Post: Armin@netPI
June-29th-2020, 09:43 PM
» Replies: 13
» Views: 73
DHCP server not working
Forum: Software
Last Post: m-yoshikawa
June-26th-2020, 05:39 AM
» Replies: 19
» Views: 106
Application developed wit...
Forum: Software
Last Post: Armin@netPI
June-24th-2020, 08:37 AM
» Replies: 4
» Views: 38
netpi-desktop-hdmi with s...
Forum: Software
Last Post: tad
June-19th-2020, 12:50 PM
» Replies: 13
» Views: 54
Node-Red "http in"-Node n...
Forum: Software
Last Post: DWxPro
June-19th-2020, 01:12 AM
» Replies: 8
» Views: 47
Admin web UI login for No...
Forum: Software
Last Post: Armin@netPI
June-18th-2020, 08:39 PM
» Replies: 1
» Views: 9
Siemens PLC -Uploading an...
Forum: Software
Last Post: MGharat
June-17th-2020, 12:34 PM
» Replies: 14
» Views: 81
NetHAT SPI configuration
Forum: Software
Last Post: Armin@netPI
June-10th-2020, 02:05 PM
» Replies: 1
» Views: 22

 
  Receive iot hub messages through MQTT adapter
Posted by: marcel - March-15th-2018, 01:50 PM - Forum: Software - Replies (1)

I'd like to receive cloud-to-device messages from iot hub in node red. I use a MQTT input node and configured it according to this: https://docs.microsoft.com/en-us/azure/i...tt-support

The only thing I am stuck is the TLS/SSL configuration. According to the article, I have to download and reference the DigiCert Baltimore Root Certificate. I wonder if this certificate is already installed or how I can install it and what to fill in in the MQTT TLS settings.


  FRAM access
Posted by: marcel - March-15th-2018, 10:17 AM - Forum: Hardware - Replies (1)

If I try that with a python:2 container, I get the following error when starting:
linux runtime spec devices: error gathering device information while adding custom device "/dev/i2c-1": lstat /dev/i2c-1: no such file or directory

Sorry, my mistake. Works perfect now.


  Problems with NTP setup
Posted by: adeeljsid - March-14th-2018, 06:31 PM - Forum: Software - Replies (4)

Hi,
I am using netPI for educational and research purposes. I have connected 5 netPI devices to a LAN (administered by pfsense) and I have configured a static IP for each. I can access them from other devices (like laptops) inside the LAN. When I try to set the NTP server for time synchronization, status becomes idle from n/a and nothing happens afterwards. II have checked several time that the Internet connectivity is available by checking Internet status on other devices in the LAN. Because of this problem, I cannot even pull the images and run it as containers. Can you please guide me what is the problem? Is it the problem with Static IPs but I don't think if its the case.

Info:
Time server: de.pool.ntp.org and tried others as well!


  Write to usb Drive from container
Posted by: SebastianSoller - March-14th-2018, 12:56 PM - Forum: Software - Replies (12)

Hello,

i am writing on a python program to write on a usb stick plugged in one of the usb ports on the NetPi. The program is working as intended but i need to write to a csv outide the Pi on a usb drive. For this i have two questions.
1. Is there a way to find the path of plugged devices and view if there are any?
2. Is it possible to write to the desired path from inside a container with the Volume settings of the container start as with the -v option when using docker on raspberry pi3

Thanks in advance,
Sebastian


  [SOLVED] Authenticate against Docker Registry
Posted by: PBulach - March-8th-2018, 02:15 PM - Forum: Software - Replies (19)

Hello,

How is it possible to authenticate to a Docker Repository to get Container which are just visible with view rights?
At Portainer.io Demo it is possible on the portainer.io web interface but the menu item is missing on the NetPi - Could it happen because of the not actual portainer.io version?

With Best Regards
PBulach


  [SOLVED] Add Trusted CA
Posted by: PBulach - March-8th-2018, 02:12 PM - Forum: Software - Replies (11)

Hello,

how is it possible to add a trusted CA to the NetPi (Portainer.io)? That is needed because it acceppts Container just from Trusted Repositories.

Best Regards
PBulach


  Inquiry on specifications of industrial grade
Posted by: LIDONG - March-7th-2018, 03:12 AM - Forum: Software - Replies (3)

Hi,

I plan to use netPI to do development and install it in the real industrial network environment. Hence, I need to make sure it can run properly for a long time without disruption. I want to inquiry if you have tested, for example:

- mean time between failure (e.g. how many hours/days)
- life cycle (e.g. > 5-10 years)
- temperature (known) and humidity (e.g. fit data center environment)

Just for example, original Raspberry Pi 3 uses SD card to boot. If SD card's life cycle is short, it may becomes a single point of failure for whole device. How about netPI? Does it uses own internal storage or external storage to boot?

Thanks.
Dong


  What is needed to be a PROFINET slave (RTE3)
Posted by: jkohlmann - March-6th-2018, 09:33 PM - Forum: Software - Replies (1)

How much work is needed to use/access ProfiNet (as Device) with netPI RTE3 ?
Do i have to buy a software stack for profiNet ? For usage within a docker image? Or is it part of System software?
The ProfiNet certification process for this device with application is still required, right?

So: what are needed todos and steps by a developer to use netPI RTE3 as ProfiNet device?


  This forum is for your projects and project ideas
Posted by: Armin@netPI - March-6th-2018, 06:21 PM - Forum: Projects - No Replies

We created this forum at the express request of the forum members to have a location where everbody can introduce his netPI project.


  Using SSH in netPI-nodered-fieldbus image
Posted by: Schranz - March-6th-2018, 09:24 AM - Forum: Software - Replies (3)

Adding the SSH portion from the https://github.com/Hilscher/netPI-contai...nvironment into the https://github.com/Hilscher/netPI-nodered-fieldbus image I was able to have access to the image.

Doing the same with the latest netPI-nodered-fieldbus image, the password does not get accepted. Could someone please have a look what I am doing wrong.
https://hub.docker.com/r/schranz/netpi-n...v6pmnnfkz/

The build log says something invoke-rc.d: policy-rc.d denied execution of start.I am totaly lost.