Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums



(Advanced Search)

Forum Statistics
» Members: 394
» Latest member: dean.leek@dematic.com
» Forum threads: 370
» Forum posts: 1,863

Full Statistics

Latest Threads
connecting a microphone v...
Forum: Software
Last Post: Armin@netPI
July-9th-2020, 07:02 AM
» Replies: 15
» Views: 48
PROFINET to OPC UA data c...
Forum: Projects
Last Post: Armin@netPI
July-7th-2020, 12:20 PM
» Replies: 0
» Views: 6
Fieldbus Ports not workin...
Forum: Software
Last Post: Armin@netPI
June-29th-2020, 09:43 PM
» Replies: 13
» Views: 73
DHCP server not working
Forum: Software
Last Post: m-yoshikawa
June-26th-2020, 05:39 AM
» Replies: 19
» Views: 106
Application developed wit...
Forum: Software
Last Post: Armin@netPI
June-24th-2020, 08:37 AM
» Replies: 4
» Views: 38
netpi-desktop-hdmi with s...
Forum: Software
Last Post: tad
June-19th-2020, 12:50 PM
» Replies: 13
» Views: 54
Node-Red "http in"-Node n...
Forum: Software
Last Post: DWxPro
June-19th-2020, 01:12 AM
» Replies: 8
» Views: 47
Admin web UI login for No...
Forum: Software
Last Post: Armin@netPI
June-18th-2020, 08:39 PM
» Replies: 1
» Views: 9
Siemens PLC -Uploading an...
Forum: Software
Last Post: MGharat
June-17th-2020, 12:34 PM
» Replies: 14
» Views: 81
NetHAT SPI configuration
Forum: Software
Last Post: Armin@netPI
June-10th-2020, 02:05 PM
» Replies: 1
» Views: 22

 
  netHat as regular ethernet interface
Posted by: jridbmdw - June-5th-2018, 08:10 AM - Forum: - Replies (2)

Hi all,

is it possible to use the nethat as a normal ethernet interface to connect to the raspberry pi?

regards


  Errormessage when trying to connect to wifi.
Posted by: BFH_SAM2 - June-4th-2018, 10:20 AM - Forum: Software - Replies (11)

We are struggling to connec't the NetPi to the WLAN of our client.

The control-panel yields following error-message:

Passwords or encryption keys are required to access the wireless network 'hegg_corp'. Warning: password for '802-11-wireless-security.psk' not given in 'passwd-file' and nmcli cannot ask without '--ask' option. Error: Connection activation failed

We can connect to the raspytest net, which we setup for test. since we do not have access to further settings we don't have any ideas what to try next?


  NetHAT with Ethernet/P and Codesys
Posted by: lstiegler - May-31st-2018, 05:07 PM - Forum: - Replies (2)

We use NetHAT Module for education purposes.
It works fine with Codesys and EtherCAT and Profinet but we have problems with Ethernet/IP.
Codesys Configuration-Tree:
Ethernet
EtherNet_IP_Scanner
NXHAT52-RTEEIS
The Codesys EtherNet_IP_Scanner does not find the NXHAT52-RTEEIS Adapter.

Do you have any idea concerning our problem?
cifxsample detects the NetHAT module.

nethatdemo output:
DeviceNumber : 7775000
SerialNumber : 20099
Firmware : EtherNet/IP Adapter
Version : 3.3.4 build 0
Date : 06/17/2016

Error writing to common status block. lRet = 0x800A0006
Error writing to extended status block. lRet = 0x800A0006

--- Event handling demo ---
Error: 0x800A001A, <>
System Error : 0x0000000E

--- Set Bus / Host State Demo ---
Set CIFX_HOST_STATE_READY!
CIFX_HOST_STATE_READ, state 1 !
Error CIFX_BUS_STATE_ON, state 1, error 0x800C0021 !
CIFX_BUS_STATE_OFF, state 0 !
Set CIFX_HOST_STATE_NOT_READY!
CIFX_HOST_STATE_READ, state 0 !
State = 0x00000000

I hope this information can help to overcome the problem.

Many thanks in advance
Bes regards
Leonhard Stiegler


  [SOLVED] Portainer does not start container
Posted by: Steres - May-23rd-2018, 07:18 AM - Forum: Software - Replies (3)

Hello,

I´m trying to start a container on Portainer, but I get the ERROR message "No such image: hilschernetpi/example : latest".
I followed the whole instructions on hub.docker.com, but it does not work.
Maybe their is an Internet problem?
I connected my netPI to a hotspot from my phone to get Internet access so I can pull images. How can I check if I have Internet access. I only can see that the netPI is connected.

Thanks in advance


  Push / Get Images from NetPi
Posted by: Jonas.Sellmann@outlook.de - May-16th-2018, 10:22 AM - Forum: Software - Replies (5)

Hello,

is there an opportunity to push images from NetPi to Docker Hub or to copy the images to a local machine.
I know that the NetPi should be used as production system only and that the development should be done on a normal raspberry pi, but somestimes I have to make some modifications in the container afterwards.

Thanks in advance,

Jonas


  Secomea Remote Acccess
Posted by: ballesj - May-15th-2018, 08:19 AM - Forum: Projects - Replies (1)

Hello !

We at RUF are looking into Secomea (https://www.secomea.com/) for secure remote access into our systems.
Secomea software supports 3rd party linux devices and runs on a standard Pi like a charm.

My idea is to use the netPi Core 3 as professional hardware and run Secomea as well as a 3G, 4G connection.

Is there any experience with this ?


  Node-Red MQTT with SSL/TLS can't connect to broker
Posted by: BFH_SAM2 - May-15th-2018, 06:15 AM - Forum: Software - Replies (6)

hey there

i'm trying to connect my node-red flow to our MQTT-Broker with a secure TLS connection (Port 8883). I have the same node-red flow on a normal raspberry pi and it works without a problem. Within the "hilschernetpi/netpi-nodered-fieldbus" docker container, it just can't connect. i checked the port with nmap within the docker container, and it says "8883/tcp open secure-mqtt" which should be allright.

I can connect to the MQTT-Broker without TLS (Port 1883) without any problems, but thats not secure enough for our application.

Do you have any ideas what to try next?

Thank you for your answer!


  Proxy Settings
Posted by: letsysro - May-9th-2018, 09:20 AM - Forum: Software - Replies (4)

Questions about proxy configuration on the netPI


  [SOLVED] Modifying ports after container is being added.
Posted by: SteveO - May-8th-2018, 09:23 PM - Forum: Software - Replies (2)

Do you know of a way to modify the ports after I’ve added the container? I need to add a port, but don’t want to redo the process.


  Custom NetX configuration files
Posted by: laythea - May-7th-2018, 06:16 PM - Forum: - Replies (2)

Hi,
I had a few questions please:

1. Is this supported for the new Raspberry Pi (3B+)?

2. My use case is as follows. I have a GSDML (version 2.3) file representing a hardware device that utilises a netx52 chip to perform Profinet IO comms to a master PLC controller. Would I be able to use this netHAT with a Pi3B+ along with my devices custom .nxb files (config.nxb and nwid_config.nxb) to create a "simulator device" for my device? Ideally I would be able to download my .nxb files to the netX via a USB loader, and then program a bit of C (directly on the netX if this is possible?) that can respond to the profinet data requests (if this is possible with the netHAT?)

Thanks in advance and I think the use of netX and the PI is very interesting.