• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
usage of hilschernetpi/netpi-netx-ethernet-lan is working but costs 25% cpu power
#1
Hi, I work in a container based on the hilschernetpi/netpi-netx-ethernet-lan image. Both RJ45 ports are working, but independent of a connected cable I have a CPU load of 25% for the cifx0daemon. For testing I used the image without any other installation, but the problem is the same. Can someone confirm that this is the normal behavior?
  Reply
#2
Can't tell you if this is normal. I will let you know if I know more details about how the driver works in details and how it is communicating with the netX chip in the background.

I will be back with information monday next week

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Many thanks for the fast replay, so I can hope that the problem can be fixed.
  Reply
#4
I see the CPU consumption of 25% myself on my netPI. Now I am curious what is the root cause of this value. I will wait for the development team to reply my question.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#5
"Now I am curious what is the root cause of this value."
Me too Armin, many thanks for your help.
  Reply
#6
Hello Michael,

we are still investigating. What we found out is that if you use the top command in the container you get the result of a 25% load. If you (only we can do it) use the top command in a seperate linux shell on the linux host the same time, you get just a load of 5%. So top command in the container and top command on the host shows different loads and we have no explanation for that.

So we are still investigating.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#7
Hello Michael,

please find appended a screen shot I made using the top command on the linux host. You see that the cifx0daemon costs just 2%-3% of CPU resources from a global view.

I googled to find any information on the web whether or not the top command works 100% the same in a container as outside, but I wasn't able to find such kind of information.

What I can tell you is that the daemon periodically calls for incoming network message cause there is no event driven communication realized between both CPUs. So you will see CPU usage even if there is no traffic on the network present and is idle.

With this result I would say it is accepted and the daemon is working normal.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#8
Many thanks Armin, I' am happy to heare this, so I will continue my work with the image!
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  normal ethernet port using for Profinet MGharat 4 28 August-7th-2019, 10:39 AM
Last Post: hannes
  [SOLVED] netPI stops working (502 - Bad Gateway) Andi 3 35 June-19th-2019, 03:58 PM
Last Post: Andi
  RTE3 Use real time ethernet as "normal" ethernet interface hannes 50 286 May-9th-2019, 04:28 PM
Last Post: Armin@netPI
  niot-e-npi3-51-en (RS485 <-> Industrial Ethernet) merklethomas 6 55 April-26th-2019, 01:38 PM
Last Post: Armin@netPI
  Modbus TCP Connection via RTE Ethernet Ports Flo_Lo 18 478 April-15th-2019, 09:50 PM
Last Post: Armin@netPI
  USB/Ethernet adapter slos 4 51 April-8th-2019, 09:11 AM
Last Post: slos
  [SOLVED] Use netX interface as profinet controller jromero248 2 60 January-10th-2019, 12:30 PM
Last Post: jromero248
  Auflösung in hilschernetpi/netpi-desktop-hdmi ändern dennis 5 152 November-15th-2018, 11:28 AM
Last Post: Armin@netPI
  [SOLVED] Usage of overlay driver adeeljsid 4 158 October-18th-2018, 10:13 AM
Last Post: Armin@netPI
  IP Realtime Ethernet michu252 7 323 August-21st-2018, 10:41 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)