• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
running ethercat slave
#1
I have compiled the below image 
  • hilschernetpi/netpi-netx-programming-examples
After excecuting ethercat slave examples, I get as below output as attached screenshot --is it the correct? EtherCAt interface is ready to use ?
Also how I can get ESI file ? I checkd t github..but how I can take it for download into Master?

Thanks & BR
Madhumati


Attached Files Thumbnail(s)
   
  Reply
#2
Well,

all the example applications provided initialize the protocol stack running in netX first and then finally end in a while loop trriggered every 1 second until a key stroke is recognized and print out the received output data from the master and mirrors the data back to input data and send it back to the master.

In your screen shot I see no output data, so your EtherCAT master did not communicate properly with the example code.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Hello Armin,

I have now connected CIFX card ( ethercat MAster ) to RTE port of netPI, when I scan network..I get output as attached screenshot. I am not able to add netPI EtehrCAT slave into configuration
Actually I am not able to find EtherCAT xml file to configure into master..how I can use it from github?

Thanks

attachment herewith


Attached Files Thumbnail(s)
   
  Reply
#4
Hello Madhumati,

the Docker Hub repository links to the container's source code on GitHub. In the github repository you find a folder named "electronic data sheets". In there you find all EDS,XML,GSDML files for all programming examples.

On github you cannot download single files. You can only get a copy of the whole github repository. So go to the main page of the githus repo and click on button "clone of download" as a zip file. Then you can extract the zip file and get you EtherCAT XML file.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#5
Ok now it is running..I attached the screeshot herewith for data exchange.

I observed that ACT LED on CIFX0 port netPI is OFF where as LINK LED is blinking fast--is it the correct state? 

Thanks & BR
Madhumati


Attached Files Thumbnail(s)
   
  Reply
#6
Well Madhumati, all the protocols firmwares on our netX chips behave the same independent on which hardware they are used on. So even if you would look to LED description for cifX 50-RE with ECS protocol stack loaded would be fine to see how EtherCAT slave LED behaviour look like.

In your case you can visit the page for the corresponding netX chip used on netPI to get knowledge about the LED behaviour. On our knowledge base thare is a section for netX chips: here https://kb.hilscher.com/display/NETX/netX+51. I am pretty sure in this section you'll find the LED description of all protocol stacks available on netX51
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#7
Hi Armin,

I checked .it is same as attached screenshot for LED states of netX.


Thanks for your support.
BR

Madhumati


Attached Files Thumbnail(s)
   
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] EtherCAT Slave snortman 5 200 February-7th-2019, 07:36 AM
Last Post: Armin@netPI
  [SOLVED] Monitoring as EtherCAT Slave PRingelberg 8 289 October-16th-2018, 08:10 PM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)