• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error when using GPIO from Python
#1
Hi,

I have a docker that runs a Python application which uses GPIOs (via the Python RPi.GPIO library).

This docker runs fine on the Raspberry Pi 3B, but not on the netPI. I get:
Code:
RuntimeError: No access to /dev/mem.  Try running as root!

Further information:
- I do start the docker container with the `--priviliged` option.
- I have not yet attached a DI DO extension the netPI. I assume the module is "just" extending the GPIOs to the outside.
- On the Raspberry Pi, I don't use portainer.
- I've upgraded the firmware of the netPI to the latest version on September 5.

Are there any differences between the netPI and Raspberry Pi concerning the GPIOs or am I doing something wrong?

Thanks,
david.
  Reply


Messages In This Thread
error when using GPIO from Python - by dcatteeu - September-9th-2019, 12:24 PM
RE: error when using GPIO from Python - by Armin@netPI - September-9th-2019, 12:31 PM
RE: error when using GPIO from Python - by dcatteeu - September-9th-2019, 04:18 PM
RE: error when using GPIO from Python - by Armin@netPI - September-9th-2019, 07:05 PM
RE: error when using GPIO from Python - by dcatteeu - September-10th-2019, 02:45 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  netPI Node-Red fieldbus node Error PersEE 5 53 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  "node-red with NIOT-E-NPIX-EVA GPIO module" Docker image Eyad.Almolki 1 149 July-30th-2018, 06:22 PM
Last Post: Armin@netPI
  Python SteveO 2 142 April-11th-2018, 06:46 AM
Last Post: Armin@netPI
  fieldbus in error Schranz 7 165 March-13th-2018, 07:28 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)