• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bluez version on netPi
#3
Hello Thomas,

I did nearly the same as you did. Use the raspbian image and installed bluez to it using apt-get install -y bluez. I started the container in priviledged mode as you did and also with host network shared, but NO host dbus shared with the container.

Entering the container with SSH I used hciconfig hci0 up and hcitool scan to test. Afterwards I tried using bluetooth -dn with debug option and it came back with /var/run/dbus/system_bus_socket: no such file error.

So I started a private dbus in the container using /etc/init.d/dbus start and then bluetoothd -dn and it starts it right away. In a second console I was able to use bluetoothctl now with the commands you proposed.

Now since this procedure let the run socket independently of the host dbus, you can now check the bluez update yourself.

Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Messages In This Thread
Answer - by Thomas - November-6th-2017, 03:22 PM
Answer - by Thomas - November-7th-2017, 08:44 AM
Answer - by Armin@netPI - November-7th-2017, 10:28 AM
Answer - by Thomas - November-7th-2017, 11:42 AM
Answer - by Armin@netPI - November-7th-2017, 12:42 PM
Answer - by Thomas - November-7th-2017, 12:49 PM
Answer - by Armin@netPI - November-7th-2017, 01:29 PM
Answer - by Thomas - November-7th-2017, 02:34 PM
Answer - by Armin@netPI - November-7th-2017, 03:24 PM
Answer - by Thomas - November-7th-2017, 03:53 PM
Answer - by Thomas - November-7th-2017, 03:54 PM
Answer - by Armin@netPI - November-7th-2017, 04:18 PM
Answer - by Armin@netPI - November-7th-2017, 04:23 PM
Answer - by Armin@netPI - November-7th-2017, 05:05 PM
Answer - by Armin@netPI - November-7th-2017, 07:00 PM
Answer - by Armin@netPI - November-8th-2017, 06:52 AM
Answer - by Thomas - November-8th-2017, 10:23 AM
Answer - by Armin@netPI - November-8th-2017, 01:11 PM
Answer - by Armin@netPI - November-8th-2017, 03:25 PM
Answer - by Armin@netPI - November-9th-2017, 08:13 AM
Answer - by Thomas - November-10th-2017, 08:25 AM

Possibly Related Threads...
Thread Author Replies Views Last Post
  BLE pairing problems with bluez 5.50 abmn 1 18 August-8th-2019, 08:51 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)