• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bluez version on netPi
#17
Hi Armin,

thank you for the excellent support! I played around a little bit and I now I have bluetooth running with the newest bluez-5.47 version. Requirement is that no userspace bluetooth software on the host system is running. So removing the bluez-package was the right decision.

Here is what I did:
- Container running in privileged mode using the host network.
- Download bluez-5.47 package and configure with following command (otherwithe hciattach tool will not be built)
# ./configure --enable-deprecated

- Build bluez package
- Download bluetooth adapter firmware file BCM43430A1.hcd and copy to /etc/firmware/
- start a dbus session
# sudo /etc/init.d/dbus start

- run hciattach to attach the hci0 adapter
# sudo hciattach /dev/ttyAMA0 bcm43xx 921600 noflow

- run bluetoothd
# sudo bluetoothd -dn

now all GATT services are discovered when connecting to a bluetooth device with the bluetoothctl tool.

Thanks you
Thomas
  Reply


Messages In This Thread
Answer - by Thomas - November-6th-2017, 03:22 PM
Answer - by Thomas - November-7th-2017, 08:44 AM
Answer - by Armin@netPI - November-7th-2017, 10:28 AM
Answer - by Thomas - November-7th-2017, 11:42 AM
Answer - by Armin@netPI - November-7th-2017, 12:42 PM
Answer - by Thomas - November-7th-2017, 12:49 PM
Answer - by Armin@netPI - November-7th-2017, 01:29 PM
Answer - by Thomas - November-7th-2017, 02:34 PM
Answer - by Armin@netPI - November-7th-2017, 03:24 PM
Answer - by Thomas - November-7th-2017, 03:53 PM
Answer - by Thomas - November-7th-2017, 03:54 PM
Answer - by Armin@netPI - November-7th-2017, 04:18 PM
Answer - by Armin@netPI - November-7th-2017, 04:23 PM
Answer - by Armin@netPI - November-7th-2017, 05:05 PM
Answer - by Armin@netPI - November-7th-2017, 07:00 PM
Answer - by Armin@netPI - November-8th-2017, 06:52 AM
Answer - by Thomas - November-8th-2017, 10:23 AM
Answer - by Armin@netPI - November-8th-2017, 01:11 PM
Answer - by Armin@netPI - November-8th-2017, 03:25 PM
Answer - by Armin@netPI - November-9th-2017, 08:13 AM
Answer - by Thomas - November-10th-2017, 08:25 AM

Possibly Related Threads...
Thread Author Replies Views Last Post
  BLE pairing problems with bluez 5.50 abmn 1 18 August-8th-2019, 08:51 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)