• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using SSH in netPI-nodered-fieldbus image
Adding the SSH portion from the https://github.com/Hilscher/netPI-contai...nvironment into the https://github.com/Hilscher/netPI-nodered-fieldbus image I was able to have access to the image.

Doing the same with the latest netPI-nodered-fieldbus image, the password does not get accepted. Could someone please have a look what I am doing wrong.

The build log says something invoke-rc.d: policy-rc.d denied execution of start.I am totaly lost.
The error is easy to explain:

if you look to our image https://hub.docker.com/r/hilschernetpi/n...n-stretch/, you see the Docker file uses this line which is made for Debian stretch

&& sed -i 's/#PermitRootLogin prohibit-password/PermitRootLogin yes/' /etc/ssh/sshd_config \

you are using the line for debian:jessie

&& sed -i 's/PermitRootLogin without-password/PermitRootLogin yes/' /etc/ssh/sshd_config \

The sshd_config file has been change from one debian OS to the other using "prohibit-password" instead of "without-password".

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Thank you very much. Does work again.
Still you should not rely on Docker Hub service only to build images remotely on the web. You need definitively a Raspberry Pi 3 to make developments yourself locally right in front of your screen. Only with a Pi 3 you have possibilities for debugging.

There will be definitively a certain point where the netPI supports ends from the forum's point of view. In detail if users build their very own container image where non of us has a clue what have been compiled together.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads...
Thread Author Replies Views Last Post
  Fieldbus Ports not working Schoko 7 52 October-29th-2019, 08:59 AM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 95 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 64 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  NodeRed and EtherCAT Schranz 1 13 September-2nd-2019, 03:46 PM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 54 August-20th-2019, 07:22 AM
Last Post: Armin@netPI
  [SOLVED] Pull Docker Image a.w.d.m. 8 43 July-8th-2019, 11:17 AM
Last Post: Armin@netPI
  [SOLVED] WebConfig netpi-nodered-fieldbus JohnyD94 13 66 May-6th-2019, 12:20 AM
Last Post: JohnyD94
  [SOLVED] node-red Dashboard Docker Image for netPI? anrodriguez 1 34 February-7th-2019, 05:35 PM
Last Post: Armin@netPI
  [INFO] Best base image to use for own containers Armin@netPI 1 117 January-15th-2019, 08:58 PM
Last Post: Armin@netPI
  [SOLVED] nodered : flows_localhost deleted after creating an image from container paubau 6 190 September-21st-2018, 10:19 AM
Last Post: paubau

Forum Jump:

Users browsing this thread: 1 Guest(s)