• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container
#1
I'm using netPI RTE with the hilschernetpi/netpi-nodered-fieldbus container installed. Now I want to activate the LED 1 an 2 (GPIO12, GPIO 13).
I try a flow with output-node Raspberry rpi gpio. But it didn`t work, below the node the message N/A is shown. Sending an e-mail using the same trigger works.


Is it even possible to access the LED with Node-Red?


Attached Files Thumbnail(s)
   
  Reply
#2
Well Christian, you should follow the following post:

https://forum.hilscher.com/thread-159.html

This explains why the standard Raspberry GPIO Node-RED node can't be used. The LEDs are no general purpose IO devices but LED devices.

Since the GPIO node is based on the rpi-gpio node.js module https://github.com/JamesBarwell/rpi-gpio...pi-gpio.js you see in there the PATH information set to /sys/class/gpio which cannot be used for the LEDs.

My recommendation is to write your own Node-RED node ... which is probably no more than 10 lines of code.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
One thing in addition. You need to enable privileged mode for your container in any case. Else the /sys/class/ ... instances are not available in a container.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#4
Thank you for your response. Unfortunately, I can not do anything with it. I understand the explanation, but creating my own node exceeds my knowledge. If you would like to give me further information, I would be grateful.

I still have a thousand more questions, but I will open new threads soon.

PS: google-Translate is wonderful
  Reply
#5
Christian I have decided to make a Node-RED LED node public within a Docker image in the next days.

I feel that an LED Node-RED example node will help the netPI community in general supporting netPI Node-RED applications better.

I will keep you informed when I have released the example.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#6
Hello Christian,

we have made the container with Node-RED and user LED node now public to everyone on DockerHub here https://cloud.docker.com/u/hilschernetpi...-user-leds

This is how it looks like

   

Have fun with it.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#7
We put all Node-RED nodes we ever made for netPI and distributed in multple containers into one single container now. https://cloud.docker.com/u/hilschernetpi...pi-nodered. This container and its Node-RED does include the user LED node too.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to save node-red flows persistent? hsammer 2 22 November-5th-2019, 03:50 PM
Last Post: hsammer
  Fieldbus Ports not working Schoko 7 45 October-29th-2019, 08:59 AM
Last Post: Armin@netPI
  Cannot start container Magnus 7 34 October-16th-2019, 01:00 PM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 53 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  Generate VLAN interfaces in container FrankJacob 7 44 September-26th-2019, 03:19 PM
Last Post: Armin@netPI
  EIP Node Red configurator mnieuzyla 4 29 September-10th-2019, 06:19 AM
Last Post: Armin@netPI
  create container in Portainer v1.12.4 dcatteeu 2 23 September-9th-2019, 12:12 PM
Last Post: dcatteeu
  UMTS/LTE support via USB router/modem sticks in a container Armin@netPI 3 153 September-5th-2019, 02:07 PM
Last Post: Armin@netPI
  Exporting and importing container images Armin@netPI 0 23 August-23rd-2019, 10:39 AM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 48 August-20th-2019, 07:22 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)