• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] WebConfig netpi-nodered-fieldbus
#9
well, I can start my deep investigations on monday first, not before.

node-red 0.20.x is out since 19'th or march. Since our container is rebuild on Docker Hub only in case its linux base image has been changed it could easily be april/may till a recompilation will bring up those incompatibilities we have detected now.

The fieldbus container has no ssh installed so doing something from remote will be difficult. But you have detected the embedded web console...

To install another version of node-red just call

Code:
npm install -g --unsafe-perm node-red@0.19.6

or 0.18.7 for the latest 18'th version.


The embedded console will be stopping to work on 1 minute idle unfortunately. We have a netPI software version v1.1.6.0 in work where this is corrected by the way.

If you want to post install ssh which makes life easier call (remember to map port 22 additionally next to 1880 and 9000 which requires to reload the container first of all)


Code:
apt-get update
apt-get install -y openssh-server
echo 'root:root' | chpasswd
sed -i 's/#PermitRootLogin prohibit-password/PermitRootLogin yes/' /etc/ssh/sshd_config
sed 's@session\s*required\s*pam_loginuid.so@session optional pam_loginuid.so@g' -i /etc/pam.d/sshd
mkdir /var/run/sshd

and edit the start script /etc/init.d/entrypoint and insert the following time whereever you want


Code:
/etc/init.d/ssh start &


restart the container then.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Messages In This Thread
RE: WebConfig netpi-nodered-fieldbus - by JohnyD94 - May-4th-2019, 08:30 PM
RE: WebConfig netpi-nodered-fieldbus - by JohnyD94 - May-4th-2019, 09:18 PM
RE: WebConfig netpi-nodered-fieldbus - by JohnyD94 - May-4th-2019, 11:52 PM
RE: WebConfig netpi-nodered-fieldbus - by Armin@netPI - May-5th-2019, 05:52 AM
RE: WebConfig netpi-nodered-fieldbus - by JohnyD94 - May-5th-2019, 07:45 AM

Possibly Related Threads...
Thread Author Replies Views Last Post
  Fieldbus Ports not working Schoko 7 44 October-29th-2019, 08:59 AM
Last Post: Armin@netPI
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 88 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 53 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  NodeRed and EtherCAT Schranz 1 11 September-2nd-2019, 03:46 PM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 48 August-20th-2019, 07:22 AM
Last Post: Armin@netPI
  [SOLVED] netPI stops working (502 - Bad Gateway) Andi 3 38 June-19th-2019, 03:58 PM
Last Post: Andi
  [SOLVED] netPI with Raspbian Desktop firefly 7 51 May-17th-2019, 09:15 AM
Last Post: Armin@netPI
  [SOLVED] node-red Dashboard Docker Image for netPI? anrodriguez 1 26 February-7th-2019, 05:35 PM
Last Post: Armin@netPI
  [SOLVED] Azure IotEdge on netPI rene.divossen 7 68 January-29th-2019, 10:37 AM
Last Post: rene.divossen
  [SOLVED] Building Custom Images for Netpi Rahulsagar 2 107 December-17th-2018, 10:01 PM
Last Post: Rahulsagar

Forum Jump:


Users browsing this thread: 1 Guest(s)