• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Pull Docker Image
When I try to pull any docker image, the only thing that happens is the name of the image and the registry disappear and nothing gets pulled.
Hi there,

did you setup the system time on netPI like shown in this video: https://www.youtube.com/watch?v=CB6bYfMbFhA

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

... or maybe this thread helps you https://forum.hilscher.com/Thread-SOLVED...ing-deploy
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

I set up the time and now I can pull public images from docker hub, but when I try to pull from my companies private azure registry it still doesn't work.
Two things need to be said

1.) While Docker Hub is a site that is officially certified by an official notified CA body (https://en.wikipedia.org/wiki/Certificate_authority), your local/private repository isn't and then Docker running on netPI denies a https pull from this "trusted" registry until its certificate is loaded onto netPI additionally.
What is necessary to allow also pulls from any own repository is to load the certificate from your repository onto your netPI. For that use the Control Panel tile on netPI's landing page and in there the option "Secutiry/Public Key Infrastructure" to upload your *.pem certificate file.

2.) In the Docker web GUI you have to use the menu option "Registry" and define your custom registry in terms of IP address and symbolik name. Doing so requires at least netPI's software version running. If the registry was setup right, if you now add a container you can now select in a drop down box you want to pull from Docker Hub or your registry.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Under Scurity I only have the option SSL/TLS Certificate.
Your netPI needs an update as I described it before. At least software version is needed. The latest version available is

Here is how it looks like:

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

How do I update? I can neither find a button nor documentation.
Using the search option in the forum here with the words "firmware update" might help you.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads...
Thread Author Replies Views Last Post
  Docker cannot find image COswald 16 67 May-18th-2020, 07:15 AM
Last Post: COswald
  PHP-Apache Image hsammer 3 10 March-12th-2020, 05:23 PM
Last Post: hsammer
  docker.service start failed EUROKEY 6 26 February-6th-2020, 09:49 AM
Last Post: EUROKEY
  After „Rebuild“ of Docker neither the node-RED nor the dashboard can be accessed MAK 4 21 January-31st-2020, 02:14 PM
Last Post: MAK
  [SOLVED] Docker GUI login issue MGharat 1 26 September-19th-2019, 11:50 AM
Last Post: Armin@netPI
Information netPI Docker REST API for versions >= V1.1.4.0 patrick 1 86 July-16th-2019, 02:45 PM
Last Post: patrick
  [SOLVED] Docker issues AlexRegev 7 195 June-26th-2019, 02:14 PM
Last Post: AlexRegev
  docker timing MGharat 2 36 June-13th-2019, 08:57 AM
Last Post: patrick
  Launching multi-containers at a time - Docker stacks Armin@netPI 0 47 June-4th-2019, 04:11 PM
Last Post: Armin@netPI
  [INFO]Docker DNS server Armin@netPI 0 22 March-7th-2019, 09:02 AM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)