• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't install Codesys License
#1
Hello,

I'm working on an Edge Gateway Connect (v. 1.1.2.0) and I installed the Codesys Container (https://hub.docker.com/r/hilschernetpi/n...sys-basis/).

Codesys container has the network interface configured as Host.

I also installed:
  • CODESYS V3.5 SP13 Patch 2
  • CODESYS Control for Raspberry Pi SL. I used the version 3.5.13.0 because, if I use the latest version (v 3.5.13.20), the connection towards the gateway is interrupted after 20 seconds from the connection.
I followed the instructions and finally I can run my Codesys program on my Edge Connect.



My program consists of an EtherNet/IP master that controls two motor.

As a next step, I bought the license for CODESYS Control for Raspberry Pi SL but I have a problem during the license activation.

In detail when I start the license activation, after few second the procedure fails with the error: "No Connection to the device. Please rescan your network"

It seems that the run-time crash. The only way to restore the connection with the gateway is to restart the run time.

Does anybody have this issue?

Thanks in advance.


Attached Files Thumbnail(s)
   
  Reply
#2
Hello Fabio,

I am sorry to say that I have never installed a valid real CoDeSys license ever on an Edge Device or netPI. So I cannot share any experience with you.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#3
Glad to hear that CoDeSys License is running in general.

Any yes indeed the CoDeSys container as it is made public today is based on debian:jessie. I could arrange to update this version to debian:stretch.

Back to your question: there is indeed a raw container https://hub.docker.com/r/hilschernetpi/n...n-stretch/ which is blank debian:stretch ... and comes without all the user space utilities provided in raspbian. If you start it don't forget to enable host mode and priviledged mode.

Let me know your experiences with it

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply
#4
Hi Armin,
with the new container with the latest Stetch distrubution inside everything is working now. License is installed like it should from the guide and now I can continue our test on ethernet ip with the drives. So I can confirm that the problem was sowhere using the old Raspbian distribution with the newest Codesys IDE and runtime.

This platform is really useful and powerful, I think that with this products the possbilities are really a lot!

Thanks you so much,
Bye
Fabio
  Reply
#5
Hello Fabio,

the CODESYS source code has been upgraded to debian stretch now.

Since the container is build automated, this may take up to 45 minutes until the cloud has build a new tag that can be downloaded for tests.

Please test this new container when it is ready and keep us informed about your results.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Codesys 3.5.14.0 MGharat 1 16 Yesterday, 09:10 AM
Last Post: Armin@netPI
  CODESYS - Control for Raspberry Florian 1 25 March-18th-2019, 06:16 PM
Last Post: Armin@netPI
  [INFI] CODESYS V3.5.14.0 compatibility confirmed Armin@netPI 0 15 February-6th-2019, 01:20 PM
Last Post: Armin@netPI
  [SOLVED] install ssh service to running container paubau 2 135 October-12th-2018, 01:03 PM
Last Post: paubau

Forum Jump:


Users browsing this thread: 1 Guest(s)