• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Broken netPI
I've got two new netPIs.
One is working flawless and the other one does not wan't to work.

When I boot the netPI, he does not send any DHCP discover telegram. (checked on the DHCP server and with Wireshark. the netPI does not send anything)
NS, SYS and POW LEDs are on, rest is constant off. (ACT does not light up some times like on the other netPI)
Even the LEDs of the Ethernet are off, even if the switch indicates a 100Mbit connection.

So I tried to do a FW update with the USB stick. (witch worked with the other netPI)

ACT LED is blinking, the Ethernet LED is on. So the bootloader seems to be alive. But even after 2 hours, the ACT LED is still blinking and the netPI does not work better.

Is there something else that I can try? Or do I really have a broken module?

Thanks for help!
Is it possible for you to connect a monitor to the HDMI of the netPI that is not working?
netPI is outputting some boot log information about what is happening to it.
If you have a picture, please append the screen shot here.

Also can you post me the http://NTxxxxxxxxxxx number you see on netPIs label please here?
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hi Armin,

Thanks for you inputs. Here you have a screenshot from the output of the module. Seems that the partition table of the flash is broken.
The MAC of the module is B827EB1118A7.

Edit: the attachment of a picture does not work for me.
But what he is telling:
switch to partition #0, OK
mmc0 is current device
** invalid partition 2 **
Wrong Image Format for bootm command
Thx for the MAC-ID. I will gonna check in the data base what happened to this device.

Then I will return with further instructions.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

The unit has been manufactured 2018-04-19 and was tested as ok.

Did you bought the unit through amazon or through the web shop?
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

I've received it as a gift during an IOT workshop from Hilscher Switzerland.
Hilscher Switzerland will get in touch with you.

Your netPI was indeed not loaded with an initial software. We need to perform this step in the lab.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] netPI stops working (502 - Bad Gateway) Andi 3 35 June-19th-2019, 03:58 PM
Last Post: Andi
  [SOLVED] netPI with Raspbian Desktop firefly 7 49 May-17th-2019, 09:15 AM
Last Post: Armin@netPI
  [SOLVED] WebConfig netpi-nodered-fieldbus JohnyD94 13 64 May-6th-2019, 12:20 AM
Last Post: JohnyD94
  [SOLVED] node-red Dashboard Docker Image for netPI? anrodriguez 1 23 February-7th-2019, 05:35 PM
Last Post: Armin@netPI
  [SOLVED] Azure IotEdge on netPI rene.divossen 7 68 January-29th-2019, 10:37 AM
Last Post: rene.divossen
  [SOLVED] Building Custom Images for Netpi Rahulsagar 2 104 December-17th-2018, 10:01 PM
Last Post: Rahulsagar
  [SOLVED] Using netPI's HDMI port Rahulsagar 2 76 December-14th-2018, 02:29 PM
Last Post: Rahulsagar
  [SOLVED] NetPI storage FULL flaminid 3 121 October-29th-2018, 08:05 PM
Last Post: Armin@netPI
  [SOLVED] Use netPi as a FTP server martech 1 105 October-18th-2018, 09:07 AM
Last Post: Armin@netPI
  [SOLVED] hilschernetpi/netpi-nodered-fieldbus Fieldbus configurator can't be open Andreas 6 196 June-11th-2018, 09:12 AM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)