• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ready-to-deploy: full featured Node-RED container
I am pleased about to announce you today the release of a full featured Node-RED container that includes all ever developed netPI specific Node-RED nodes (until now they were offered in separate containers). Those are

  • netpi-nodered-npix-rs232
  • netpi-nodered-npix-rs485
  • netpi-nodered-npix-io
  • netpi-nodered-npix-ai
  • netpi-nodered-user-leds
  • netpi-nodered-nxpix-leds
  • node-red-contrib-fieldbus (on netPI RTE 3 only)
  • node-red-contrib-fram (on netPI RTE 3 only)
Additionally it includes some community maintained nodes we feel they are a must have on netPI in case Node-RED is the choice. Those are

  • node-red-contrib-generic-ble
  • node-red-contrib-modbus
  • node-red-contrib-opcua
  • node-red-dashboard
As usual we are offering the container ready for your deployment on our netPI repository here.

Have fun with it.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

Hi Armin,

I've been trying to use the above node RED container.
After successfully adding it the container state is stuck on "Created" (left column on the container list tab).
I am trying to make it start but the state doesn't change and the Node RED page is not accessible from port 1880 as it should be according to the instruction page.

Appreciate your help,

Hi Alex,

have you a netPI RTE or a netPI Core?
Do you have any other containers running (e.g. an other container using/occupying an already mapped device)?

Best Regards
Hi Patrick,

Thank you for your quick answer.
I'm using a NetPI RTE3.
No i have stopped all other containers. at some point i even deleted all other containers and left only the node RED and the result is the same.


Hi, just checking. Is this correct?

I'm using NIOT-E-NPI3-51-EN-RE and the store (https://www.netiot.shop/epages/es767660....s/1321.428) the unit i'm using is RTE

Container prerequisites
Image tags

Choose an image tag depending on the netPI target device in use:

Use tag core3 for device netPI CORE 3 (NIOT-E-NPI3-51-EN-RE)

Use tag rte3 for device netPI RTE 3 (NIOT-E-NPI3-EN).
Hi there,

yes your understanding is correct. The term RTE stands for "Real Time Ethernet" and is the marketing name for a netPI with on-board netX chip that supports protocols like PROFINET,EtherCAT etc. netPI CORE is the unit that has no netX and is more or less the very same device as the original Raspberry Pi 3B but in industrial format.

You never fail until you stop trying.“, Albert Einstein (1879 - 1955)


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to save node-red flows persistent? hsammer 2 27 November-5th-2019, 03:50 PM
Last Post: hsammer
  [SOLVED] activate LED1/2 with Node-RED + fieldbus nodes container Christian_Rau 6 91 October-21st-2019, 10:30 AM
Last Post: Armin@netPI
  Cannot start container Magnus 7 40 October-16th-2019, 01:00 PM
Last Post: Armin@netPI
  netPI Node-Red fieldbus node Error PersEE 5 59 October-8th-2019, 03:55 PM
Last Post: Armin@netPI
  Generate VLAN interfaces in container FrankJacob 7 46 September-26th-2019, 03:19 PM
Last Post: Armin@netPI
  EIP Node Red configurator mnieuzyla 4 32 September-10th-2019, 06:19 AM
Last Post: Armin@netPI
  create container in Portainer v1.12.4 dcatteeu 2 24 September-9th-2019, 12:12 PM
Last Post: dcatteeu
  UMTS/LTE support via USB router/modem sticks in a container Armin@netPI 3 157 September-5th-2019, 02:07 PM
Last Post: Armin@netPI
  Exporting and importing container images Armin@netPI 0 27 August-23rd-2019, 10:39 AM
Last Post: Armin@netPI
  [SOLVED] Help with fieldbus node Farani 5 53 August-20th-2019, 07:22 AM
Last Post: Armin@netPI

Forum Jump:

Users browsing this thread: 1 Guest(s)