• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Modbus TCP Connection via RTE Ethernet Ports
#7
Thanks for your quick answer.
Even if I comment these lines out I get the error with your Ethernet across Industrial Ethernet ports image.
I get this error when Docker tries to run the apt-get update ... line.
Any Ideas why this is happening?
Do I need to choose another debian:jessie image?

--------------
Docker Build output
--------------
Step 1/8 : FROM resin/armv7hf-debian:jessie
---> 16a1a7000edb
Step 2/8 : LABEL maintainer="netpi@hilscher.com" version="V0.9.1.0" description="netX based TCP/IP network interface"
---> Using cache
---> bf0e0d9efee1
Step 3/8 : ENV HILSCHERNETPI_NETX_TCPIP_NETWORK_INTERFACE_VERSION 0.9.1.0
---> Using cache
---> 4879940e35e0
Step 4/8 : COPY "./init.d/*" /etc/init.d/
---> Using cache
---> f39f214d4000
Step 5/8 : COPY "./driver/*" "./firmware/*" /tmp/
---> Using cache
---> 5d50783c4c77
Step 6/8 : RUN apt-get update && apt-get install -y openssh-server build-essential && useradd --create-home --shell /bin/bash pi && echo 'root:root' | chpasswd && echo 'pi:raspberry' | chpasswd && adduser pi sudo && mkdir /var/run/sshd && sed -i 's/PermitRootLogin without-password/PermitRootLogin yes/' /etc/ssh/sshd_config && sed 's@session\s*required\s*pam_loginuid.so@session optional pam_loginuid.so@g' -i /etc/pam.d/sshd && dpkg -i /tmp/netx-docker-pi-drv-1.1.3.deb && dpkg -i /tmp/netx-docker-pi-pns-eth-3.12.0.8.deb && gcc /tmp/cifx0daemon.c -o /opt/cifx/cifx0daemon -I/usr/include/cifx -Iincludes/ -lcifx -pthread && rm -rf /tmp/* && apt-get remove build-essential && apt-get -yqq autoremove && apt-get -y clean && rm -rf /var/lib/apt/lists/*
---> Running in 48aa168c4293
cgroups: cannot find cgroup mount destination: unknown

Also there is an error in the development container:

--------------
Build Container Log
--------------

2018-06-29T06:47:41.518814961Z mount: cgroup is already mounted or /sys/fs/cgroup/cpu busy
2018-06-29T06:47:41.544934996Z cgroup is already mounted on /sys/fs/cgroup/cpuset
2018-06-29T06:47:41.559020764Z mount: cgroup is already mounted or /sys/fs/cgroup/cpuacct busy
2018-06-29T06:47:41.560117218Z cgroup is already mounted on /sys/fs/cgroup/cpuset

Does this have something to do with the error from within the docker building process?
  Reply


Messages In This Thread
Answer - by Flo_Lo - June-20th-2018, 12:17 PM
Answer - by Armin@netPI - June-20th-2018, 02:01 PM
Answer - by Flo_Lo - June-27th-2018, 05:48 PM
Answer - by Armin@netPI - June-28th-2018, 06:54 AM
Answer - by Flo_Lo - June-28th-2018, 05:11 PM
Answer - by Armin@netPI - June-28th-2018, 06:58 PM
Answer - by Flo_Lo - June-29th-2018, 07:49 AM
Answer - by Armin@netPI - June-29th-2018, 10:47 AM
Answer - by Armin@netPI - July-3rd-2018, 10:26 AM
Answer - by crthomas1234 - July-10th-2018, 04:22 PM
Answer - by Armin@netPI - July-10th-2018, 07:35 PM
Answer - by Armin@netPI - July-10th-2018, 07:46 PM
Answer - by crthomas1234 - July-11th-2018, 06:51 PM
Answer - by Armin@netPI - July-12th-2018, 07:02 AM
Answer - by Armin@netPI - July-12th-2018, 12:02 PM
Answer - by crthomas1234 - July-12th-2018, 02:13 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  normal ethernet port using for Profinet MGharat 4 32 August-7th-2019, 10:39 AM
Last Post: hannes
  [SOLVED] Slow network connection Andi 5 31 May-22nd-2019, 05:16 PM
Last Post: Armin@netPI
  RTE3 Use real time ethernet as "normal" ethernet interface hannes 50 307 May-9th-2019, 04:28 PM
Last Post: Armin@netPI
  niot-e-npi3-51-en (RS485 <-> Industrial Ethernet) merklethomas 6 58 April-26th-2019, 01:38 PM
Last Post: Armin@netPI
  USB/Ethernet adapter slos 4 52 April-8th-2019, 09:11 AM
Last Post: slos
  IP Realtime Ethernet michu252 7 324 August-21st-2018, 10:41 AM
Last Post: Armin@netPI
  [SOLVED] Modifying ports after container is being added. SteveO 2 132 May-9th-2018, 02:39 PM
Last Post: SteveO
  3 Network Ports possible on NIOT-E-NPI3-51-EN-RE? yulian 7 198 April-3rd-2018, 02:57 PM
Last Post: Armin@netPI
  NodeRed Modbus Flow iotuser 1 83 March-27th-2018, 11:14 AM
Last Post: Armin@netPI
  usage of hilschernetpi/netpi-netx-ethernet-lan is working but costs 25% cpu power Michael_d 7 158 March-9th-2018, 10:52 AM
Last Post: Michael_d

Forum Jump:


Users browsing this thread: 1 Guest(s)