• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Modbus TCP Connection via RTE Ethernet Ports
#4
Hi Flo,

the Node-RED fieldbus example is automatically loading a different firmware into the netX chip. This means starting two containers - one with LAN and one with PROFINET/Ethernet/IP - at the same time will never work. It is not predicable which container will succeed and in which order they are started. So this is a dead end.

Here is how I would do it: I would create my very own container. I would keep the LAN example like it is and would add from the fieldbus container github project the following source code lines from the dockerfile and would copy them into the netX LAN example and rebuild the new container.

#install node.js V8.x.x
url -sL https://deb.nodesource.com/setup_8.x | sudo -E bash - \
&& apt-get install -y nodejs \
#install Node-RED
&& npm install -g --unsafe-perm node-red \

This would just install node.js and node-red ... and no additional netX driver and fieldbus nodes that would cause a firmware reload into netX chip destroying your LAN interface.

As next I would modify the entrypoint.sh of the LAN example and would add a /usr/bin/node-red after the cifx0daemon has been loaded to let start node-red at each boot. Please do not forget to map port 1880 when starting the container.





You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

  Reply


Messages In This Thread
Answer - by Flo_Lo - June-20th-2018, 12:17 PM
Answer - by Armin@netPI - June-20th-2018, 02:01 PM
Answer - by Flo_Lo - June-27th-2018, 05:48 PM
Answer - by Armin@netPI - June-28th-2018, 06:54 AM
Answer - by Flo_Lo - June-28th-2018, 05:11 PM
Answer - by Armin@netPI - June-28th-2018, 06:58 PM
Answer - by Flo_Lo - June-29th-2018, 07:49 AM
Answer - by Armin@netPI - June-29th-2018, 10:47 AM
Answer - by Armin@netPI - July-3rd-2018, 10:26 AM
Answer - by crthomas1234 - July-10th-2018, 04:22 PM
Answer - by Armin@netPI - July-10th-2018, 07:35 PM
Answer - by Armin@netPI - July-10th-2018, 07:46 PM
Answer - by crthomas1234 - July-11th-2018, 06:51 PM
Answer - by Armin@netPI - July-12th-2018, 07:02 AM
Answer - by Armin@netPI - July-12th-2018, 12:02 PM
Answer - by crthomas1234 - July-12th-2018, 02:13 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  Fieldbus Ports not working Schoko 7 45 October-29th-2019, 08:59 AM
Last Post: Armin@netPI
  normal ethernet port using for Profinet MGharat 4 35 August-7th-2019, 10:39 AM
Last Post: hannes
  [SOLVED] Slow network connection Andi 5 31 May-22nd-2019, 05:16 PM
Last Post: Armin@netPI
  RTE3 Use real time ethernet as "normal" ethernet interface hannes 50 308 May-9th-2019, 04:28 PM
Last Post: Armin@netPI
  niot-e-npi3-51-en (RS485 <-> Industrial Ethernet) merklethomas 6 59 April-26th-2019, 01:38 PM
Last Post: Armin@netPI
  USB/Ethernet adapter slos 4 52 April-8th-2019, 09:11 AM
Last Post: slos
  IP Realtime Ethernet michu252 7 324 August-21st-2018, 10:41 AM
Last Post: Armin@netPI
  [SOLVED] Modifying ports after container is being added. SteveO 2 132 May-9th-2018, 02:39 PM
Last Post: SteveO
  3 Network Ports possible on NIOT-E-NPI3-51-EN-RE? yulian 7 199 April-3rd-2018, 02:57 PM
Last Post: Armin@netPI
  NodeRed Modbus Flow iotuser 1 83 March-27th-2018, 11:14 AM
Last Post: Armin@netPI

Forum Jump:


Users browsing this thread: 1 Guest(s)