• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect without DHCP
#11
Afet, we have a problem in the forum to append attachments currently. So I can't see the details unfortunately. Maybe you have a chance to hand me over the 2 x 3-4 parameters in writing as text.

Wat I can tell you is that loading the application - and I suppose you mean loading a container - has no effect on the main system respectively the LAN and Wifi settings. They are started as services far before the Docker daeon is started during the boot sequence and hence are established.
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

#12
Hi Armin,

LAN: fixed address
IP: 192.168.0.10
Subnet: 255.255.255.0
DNS1: 192.168.100.1

WiFi:
IP: 192.168.100.135
Subnet: 255.255.255.0
Gateway: 192.168.100.1
DNS1: 192.168.100.1

Modbus I/O:
Static IP: 192.168.0.212

Thanks,
Afet



#13
Hello Afet,

I setup 100% the same settings as you have described. Same LAN settings and also I setup a Wifi router with the same IP address range etc.

Then I checked to modify the LAN settings in the web interface as you described. I changed for example the LAN IP address from 192.168.0.10 to 192.168.0.11 ... and netPI changed it to that value. I am not able to get a scenario where netPI changes back its settings to DHCP.

Can you give me a hint which value to change from all your values stated that causes your netPI to change back to DHCP please?
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

#14
Hi Armin,

Can you try to change back to DHCP while running a container in host mode? If you don't notice any issues, then we can close the topic for now. We have not encountered the same problem after a factory reset. If it happens again, I will let you know.

Thanks,
Afet
#15
Checked it again as you recommended. Can't get it reconstructed.

Thx
Armin
You never fail until you stop trying.“, Albert Einstein (1879 - 1955)

#16
Thread closed


Possibly Related Threads...
Thread Author Replies Views Last Post
  Errormessage when trying to connect to wifi. BFH_SAM2 11 380 September-24th-2018, 12:52 PM
Last Post: Armin@netPI
  Connect to PLC without knowing IP paubau 12 422 August-22nd-2018, 03:06 PM
Last Post: Armin@netPI
  Node-Red MQTT with SSL/TLS can't connect to broker BFH_SAM2 6 243 May-18th-2018, 08:48 AM
Last Post: Armin@netPI
  DHCP/DNS issue: Couldn't access NetPI3 out-of-the-box zulliger@software-natives.ch 5 181 March-14th-2018, 06:47 PM
Last Post: adeeljsid

Forum Jump:


Users browsing this thread: 1 Guest(s)